Chevelle Question - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Jul 1st, 04, 06:10 PM Thread Starter
Tech Team
BARRY
 
Join Date: Apr 2000
Location: georgetown
Posts: 46
Send a message via AIM to BARRY
Question

I have a 72 Chevelle, that when it is running, whether it is sitting still or driving down the road, the generator light will blink on and off and I can hear a slight clicking noise under the hood. I replaced the voltage regulator, but that didn't work. Checked the alternator wires, everything is working, and the alternator is charging. The light ( generator) will get bright, then it will dim down a little. Checked the belts also to see if they were loose, nothing. What could the problem be? Any help would be appreciated.
BARRY is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Jul 2nd, 04, 04:28 PM
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Post

Bad connection somewhere. Wiggle test it.

Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome