Tach&Gen light on - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jan 1st, 01, 04:51 PM Thread Starter
 
Join Date: Dec 2000
Location: Federal Way WA USA
Posts: 5
Post

Trying to bring a 68 Z28 back to life.It has a 302 and 4 speed man trans.When the key is off the tach and Gen. light stay on,sometimes.The lights are dimmer than in the on position and the Gen light goes off when the engine is running,also the Alt. is charging the battery.We've been disconnecting the battery cause it will drain flat when the lights want to come on in the middle of the night.Thanks for your help. John
johnrose is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jan 2nd, 01, 06:34 AM
Senior Tech
 
Join Date: Mar 2000
Location: Dtown PA
Posts: 820
Post

sounds like it has a "on" where a switched circut is supposed to be, or the coil is on constantly, get a test light and go down the fuse block with the key off and the lights "dimmed" as yoou described. see whats draining, you should have power only to "BATT" terminal devices.

------------------
Chris's 67 RS can be seen at http://www.67rs.com
JOIN THE CAMARO NET WEBRING!
http://nav.webring.yahoo.com/hub?ring=camaronet&list
Chris Edwards is offline  
post #3 of 4 (permalink) Old Jan 2nd, 01, 07:34 AM
Senior Tech
 
Join Date: Aug 1999
Location: Ontario, Canada
Posts: 564
Post

I would look at the voltage regulator, sounds like a set of contact points are sticking within the voltage regulator, use a point file to get a good contact surface for each of the points.
Rob.Canada is offline  
 
post #4 of 4 (permalink) Old Jan 4th, 01, 02:38 PM Thread Starter
 
Join Date: Dec 2000
Location: Federal Way WA USA
Posts: 5
Post

I think we will try a new voltage regulator, im going to put in a cheap 15 dollar one. thank you for the advice!
johnrose is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome