Turn signal wiring harness help - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Mar 18th, 05, 06:53 AM Thread Starter
 
Join Date: Jan 2005
Posts: 251
Post

I just installed the wiring harness on my 68 for the turn signal and a new turn signal cam.

my problem is that i cant get the 3 bolts to screw in far enough to get that back retainer plate. I've tried everything. is there a trick?

Also, everything works ... except the left turn signal wont blink... it just lights up. all bulbs are new and plenty of good grounds. Any thoughts on this one?
maxharvard is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Mar 20th, 05, 04:35 AM
 
Join Date: Mar 2005
Posts: 165
Post

This work for me just yesterday I was having the same problem. try turning your connection to the light bulb. Pull out the plastic connector and turn by 1/2. Hope it helps.
rookie68camaro is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome