replacing headlight and troubleshooting turn signal - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Jul 1st, 04, 03:32 PM Thread Starter
 
Join Date: Jun 2004
Posts: 1
Post

Hi there - my roommate has a '95 Camaro with 2 problems that I'm trying to sort out.

First was a bad headlight. Seems easy enough. We bought a replacement for it and when I sat down to fix it this evening I ran into problems. It seems that the headlight assembly fits into a bracket which is then held into place by a spring on the bottom and a screw that tightens down on the top. The spring on the bottom is gone and so the headlight is relatively loose in there. What do I do??!

2nd problem is that the left signal isn't working - it stays solid when the driver tries to signal. Right works fine. Both front and back so I'm thinking this may be a fuse issue? How do I troubleshoot it? I couldn't even find the fuse box in the car and my roommate doesn't have the manual anymore.

Thanks for your help!

G
uogecko is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome