pertronix and no spark at coil - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Aug 9th, 04, 07:29 PM Thread Starter
Tech Team
 
Join Date: Apr 2000
Location: Orlando, FL
Posts: 59
Post

I've got a Pertronix distributor with the Igniter 2 unit in it. I've also got a Pertronix coil. Both are less than 6 months old. I run this car every day, but have had trouble starting it off and on for last two weeks. Now it absolutely won't start and I'm getting zero spark from the coil. Any ideas?
I've swapped the coil for one that I know works and no dice. All connections are tight. Is it possible that the Ignitor unit died already? Would that cause no spark at the coil?
Thanks.

'67 Camaro Convertible Rally Sport<br />'03 Harley-Davidson Heritage Classic
convertibleRS is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Aug 10th, 04, 04:24 PM
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Post

Does it require a ballast resistor or resistor wire? If so, are you running one? Does your voltage regulator keep the system voltage below 14 volts?

Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome