Junction Block/ Positive Ground Did I make I mistake???? - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Aug 15th, 01, 02:30 PM Thread Starter
Tech Team
 
Join Date: Jul 2001
Location: Rochester
Posts: 31
Red face

I got the notion to install a battery mat so I changed the positive terminal @ the battery & cleaned the postive ground at the junction block. I used steel wool to get the rust off the juction block stud. I also inserted a new washer-[with the points on it;like a star] in -between the one against the car & the wires. The lights would flicker only slightly before & only in gear.I thought I was fixing the problem now they are worse than ever. What did I do & why? What are my next steps? Thnak you in advance.

1968 327 factory coupe.
Joe R is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Aug 15th, 01, 03:55 PM
Senior Tech
Mark
 
Join Date: Sep 2000
Location: Shrewsbury, MA, USA
Posts: 6,509
Post

That terminal is not a positive ground, its just a stud to connect the main power lead to the battery. The terminal bolts to the radiator support, and then the wires go on the stud, then the nut goes on the stud. Do not allow the terminals on the wires to touch the radiator support or you will short out your battery.


------------------
Mark Canning
1969 Indy Pace Car
350/300HP RPO Z11
My 69 Pace Car
Mark C is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome