68 or 69 AC relay switch - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old Aug 10th, 04, 06:48 AM Thread Starter
Senior Tech
Dave
 
Join Date: Jan 2000
Location: Burley, Idaho, USA
Posts: 496
Post

I'm going to replace my relay switch for ac and in looking at catalogs, I see many 68 switches which appear to be the same as the one on my 69. I can't seem to find any for a 69 that show a picture. Are they the same switch or are there differences between the two that you can't see?
Any help is always appreciated..

Dave, 69 Coupe, 383, Q-jet, Thorley headers, 350 turbo, P.S., P.B. console gauges, Tilt wheel, Black with green pearl paint, Black and White Houndstooth interior.
Black69 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old Aug 10th, 04, 07:43 AM
Senior Tech
 
Join Date: Nov 2001
Location: San Angelo,TX,USA
Posts: 612
Post

Could this be what your looking for ?

Ricks First Gen Part # RC 202 1969 A/C Relay top of the box
Rsmith1969 is offline  
post #3 of 7 (permalink) Old Aug 10th, 04, 08:14 AM Thread Starter
Senior Tech
Dave
 
Join Date: Jan 2000
Location: Burley, Idaho, USA
Posts: 496
Angry

That is probably the part I need. It does appear to be different from the one that is on the car now, as far as the prongs go. It also appears that I have a relay from a 68 on there now. Does anyone know if the are different other than cosmetically.

Dave, 69 Coupe, 383, Q-jet, Thorley headers, 350 turbo, P.S., P.B. console gauges, Tilt wheel, Black with green pearl paint, Black and White Houndstooth interior.
Black69 is offline  
 
post #4 of 7 (permalink) Old Aug 10th, 04, 11:42 AM
Retired
Jim
 
click's Avatar
 
Join Date: Jun 2001
Location: Central Minnesota
Posts: 15,985
Post

This should be the relay you want. Some catalogs dont agree and give you the wrong one and then it doesnt work right, I went thru 3 before insisting on the right tabs . Hope this helps.

Click..is Jim..former owner of a 69RS-LM1 350/255 - 700r
"There will come a time when you believe everything is finished,
That will be the beginning." Louis L'Amour
click is offline  
post #5 of 7 (permalink) Old Aug 10th, 04, 12:28 PM Thread Starter
Senior Tech
Dave
 
Join Date: Jan 2000
Location: Burley, Idaho, USA
Posts: 496
Red face

The relay I took off is that same as the one you show in appearance. However the tab for the ground is in the number 4 postition rather than the 5 position. I don't know if this is correct as this relay matches the ones for 67-68 in the catalogs and I was told that some go from 68-72. Any ideas??? I don't know if this relay was original to the car.

Dave, 69 Coupe, 383, Q-jet, Thorley headers, 350 turbo, P.S., P.B. console gauges, Tilt wheel, Black with green pearl paint, Black and White Houndstooth interior.
Black69 is offline  
post #6 of 7 (permalink) Old Aug 10th, 04, 04:52 PM
Retired
Jim
 
click's Avatar
 
Join Date: Jun 2001
Location: Central Minnesota
Posts: 15,985
Post

I tried the relay with ground in #4 position and the fan didnt work on high speed. When I put this one in place (pic), it fired right up and works on all 4 speeds nicely. print out this pic, take it to your napa or auto parts store and they can get you their catalog that shows the relay and its tabs. Then order the one that matches this one. you should be good to go then.

Click..is Jim..former owner of a 69RS-LM1 350/255 - 700r
"There will come a time when you believe everything is finished,
That will be the beginning." Louis L'Amour
click is offline  
post #7 of 7 (permalink) Old Aug 15th, 04, 12:32 PM Thread Starter
Senior Tech
Dave
 
Join Date: Jan 2000
Location: Burley, Idaho, USA
Posts: 496
Angry

Thanks for everyone's help. I found that many resto catalogs sell the relay that actually is for 67-68 cars to include 69-70. This is for the high speed. If you use the wrong one you will have no high speed. I also found that NAPA has the correct one for 69 which is different from the 67-68. Echlin AR108 is the correct part number, $19.69 + tax.
Black69 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome