Horn fuse - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Mar 4th, 05, 09:05 AM Thread Starter
 
Join Date: Mar 2005
Posts: 2
Post

Please Help
my horn fuse keeps blowing
i know that the lighter, dome & map lights,
hatch release & door locks are all on the same
fuse. the short only happens when the door is open
i know the short will go away if i close the door
or remove the dome light bulb. (testing for short
off the lighter) am i missing somthing is there
a relay or somthing that might have gone bad.
i have traced wires as far as i can without ripping the whole dash apart.
adf1571 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Mar 4th, 05, 01:25 PM
Gold Lifetime Member
Harry
 
dawg's Avatar
 
Join Date: Mar 2004
Location: Colebrook CT.
Posts: 4,043
Post

check horn relay on the drivers side radiator support.
Assuming your talking about a first gen camaro?
to get rapid responses in the future include make , model, year of car


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

434 stroker
US Navy retired

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dawg is offline  
post #3 of 5 (permalink) Old Mar 4th, 05, 02:07 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Post

don't think itsa first gen, never saw one with a map light, not to mention a "hatch release". Besdies, on a first gen, the horn and the courtesy lights ain't on the same fuse...





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
 
post #4 of 5 (permalink) Old Mar 4th, 05, 07:06 PM Thread Starter
 
Join Date: Mar 2005
Posts: 2
Post

Sorry i forgot to mention it is a 1991 Z28
adf1571 is offline  
post #5 of 5 (permalink) Old Mar 6th, 05, 05:59 PM
Team Member
John
 
JohnZ's Avatar
 
Join Date: Sep 2000
Location: Washington, Michigan USA
Posts: 7,728
Post

The horn circuit on a 1st-Gen isn't fused at all; when the relay contacts close, the green wires are connected directly to battery power at the screw terminal bus. [img]graemlins/thumbsup.gif[/img]

JohnZ
CRG
JohnZ is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome