check engine light - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Sep 7th, 02, 11:25 AM Thread Starter
Tech Team
 
Join Date: Sep 2002
Location: newport news va
Posts: 43
Please help, I bought an 85 IROC 305 TPI 700 R4 tranny. Got it home and rebuilt the engine. Bored 30 over upped the cam but stayed computer friendly. Put 194 valves in. Turned the crank. Started the car and had a few codes. Ran the codes and replaced the MAF, and the MAT. Started up and got an O2 sensor bad (44). Replaced the O2 and started back up after a min of the car running good got a 44 again O2 sensor. If I shut down and restart it runs good again for a min then hunts up to about 2 grand and check engine light comes on. Code 44. I never put the smog pump back on and I capped off the manifold with plugs, along with the breather tube for the cat. The car has great pick up. If I stomp it the car throws me in the trunk even with the engine light on. However it runs rough and hard to idle at a light. Check engine light at idle in drive is 400 or 500 to a stall, off is 750. Any ideas? Thanks for your time and any help.

Jeff
85iroc is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Sep 8th, 02, 04:31 AM
Senior Tech
 
Join Date: May 2002
Location: Kingsland, Georgia
Posts: 326
Welcome Jeff,
Is the MAF installed correctly? Don't laugh I've seen them installed backwards (upside down) there should be an arrow on it indicating air flow.

Code 44 is a lean exhaust not always O2 sensor.

Are you using a scanner or jumping the connector and reading "flash" codes?

What kind of vacuum reading are you getting at idle?

If you have a scanner does the ECM go into "closed loop" operation?

With a scanner, what kind of "fuel trim" values are you seeing (they should be around 128).

Post more info.

Drew
drew69 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome