Ground straps - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Aug 16th, 00, 03:40 PM Thread Starter
Senior Tech
 
Join Date: Jun 2000
Location: Las Vegas, NV
Posts: 144
Question

When I was detailing my engine bay before intalling my new engine, I noticed 3 braided copper straps that I assume are ground connections. One goes from the firewall to the frame but the other 2 are just hanging from the firewall. They weren't attached when I pulled the engine so I don't know where they should be connected. They look like they would line up with the trans to engine bolts. If yes, any particular ones? I'm assuming they need a little slack. Any insight would be appreciated.
POP D TOP is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Aug 16th, 00, 03:43 PM
Senior Tech
Steve
 
mccorry's Avatar
 
Join Date: Apr 1999
Location: Grove City, Ohio, USA
Posts: 1,658
Garage
Thumbs up

I believe they go to the valve cover bolts (one for each side / top rear bolt).

------------------
Steve McCorry - Central Ohio Camaro Club
'69 Camaro RS/SS-350 - Daytona Yellow
'95 Camaro Z-28 - Sebring Silver
click here to see my car ---> www.mindspring.com/~mccorry(updated 8/14/00)
mccorry is offline  
post #3 of 4 (permalink) Old Aug 16th, 00, 07:31 PM
 
Join Date: Jul 2000
Posts: 233
Post

Yes mccorry, they do go to both valve covers. They were called radio ground straps. The driver side one mounts to the first bolt on the tire side of cover and the passenger side one mounts to the first bolt on the intake side of the valve cover. Bob
69er is offline  
 
post #4 of 4 (permalink) Old Aug 17th, 00, 03:17 AM Thread Starter
Senior Tech
 
Join Date: Jun 2000
Location: Las Vegas, NV
Posts: 144
Thumbs up

Thanks guys! Just what I needed to know. "MDowney" also sent me the page from the assembly manual verifying exactly what you're saying.

By the way if I get the rest of the car looking as good as the engine, I'm gonna be one happy pappy! This forum is great thanks everyone for all the help!
POP D TOP is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome