wiper motor hitting valve cover - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 19 (permalink) Old Mar 17th, 05, 01:16 PM Thread Starter
 
Join Date: Jun 2004
Posts: 63
Post

I have a 67 camaro and installed tall valve covers on the engine and now they hit the wiper motor. Does any one know of an easy fix.
junbug is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old Mar 18th, 05, 02:27 AM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Post

shorter valve covers? this a big block or asmall block? y 327 has "fairly tall" alluminum valve covers, WITH a breather in that corner, and they cleared. yours must be huge!





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #3 of 19 (permalink) Old Mar 18th, 05, 02:35 AM
Gold Lifetime Member
Harry
 
dawg's Avatar
 
Join Date: Mar 2004
Location: Colebrook CT.
Posts: 4,045
Post

i seen this happen to guys that use bigblock mounts on a smallblock before


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

434 stroker
US Navy retired

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dawg is offline  
 
post #4 of 19 (permalink) Old Mar 18th, 05, 02:47 AM Thread Starter
 
Join Date: Jun 2004
Posts: 63
Post

The valve covers I have are Edelbrock elite
and I have stock small block motor mounts.
I can't use the shorter valve cover because of the cam and roller rocker combo. They hit the shorter
valve covers.
junbug is offline  
post #5 of 19 (permalink) Old Mar 18th, 05, 03:55 AM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Post

something don't make sense then... can you post a pic?





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #6 of 19 (permalink) Old Mar 18th, 05, 11:04 AM Thread Starter
 
Join Date: Jun 2004
Posts: 63
Post

Do you have the measurment of the small block mounts.
junbug is offline  
post #7 of 19 (permalink) Old Mar 18th, 05, 11:28 AM Thread Starter
 
Join Date: Jun 2004
Posts: 63
Post

Here is a link. Maybe I'm doing somthing wrong?
http://hobbystage.net/camaro/junebug40/
junbug is offline  
post #8 of 19 (permalink) Old Mar 18th, 05, 11:45 AM
Gold Lifetime Member
Jack
 
Join Date: Sep 2000
Location: Gilbert, Az. USA
Posts: 1,677
Post

I also have tall covers and I do need to remove the wiper motor to remove the cover. Your covers seem to be a 1/2 in. or so taller than mine. That would be enough to remove any clearance there was.

67 RS
Royal Plum/Parchment
6.0 LSX 4L80e

06 corvette Z06
machine silver
jackr is offline  
post #9 of 19 (permalink) Old Mar 20th, 05, 09:20 AM
 
Join Date: Mar 2004
Posts: 537
Post

www.detroitspeed.com

selecta speed wiper motor, will clear most applications

its a $300 fix, lol which may not be so easy for some, but its an option
aonghus is offline  
post #10 of 19 (permalink) Old Mar 20th, 05, 09:29 AM
 
Join Date: Aug 2003
Posts: 154
Post

I had problem with the valve covers hitting the valve train componets. Found out my Valve Covers where on the wrong side; had passenger side on drivers side and visa versa. I did not know they were side specific. They were slightly angled. swaped side problem gone.

How are you phasing your wiper motor. I have seen them installed wrong and interfer with valve covers.
Also are you using the one-piece reuseable style mr gasket or felpro gaskets (around $29 a pair) cant think of better way to describe them. I am not sure of part numbers but some add about a 1/4-inch height to covers even when cranked down on.

just my 0.02
WillS is offline  
post #11 of 19 (permalink) Old Mar 20th, 05, 10:51 AM
Gold Lifetime Member
Harry
 
dawg's Avatar
 
Join Date: Mar 2004
Location: Colebrook CT.
Posts: 4,045
Post

man your motor is really high in the pics?
are you positive you have the correct engine mounts in there?(engine crossmember mount aswell)
I have tall valve covers on my car and got at least 1 to 2 inches of clearance there?
heres a pic:
http://webpages.charter.net/harrycoo...%20of%20engine


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

434 stroker
US Navy retired

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dawg is offline  
post #12 of 19 (permalink) Old Mar 20th, 05, 01:37 PM Thread Starter
 
Join Date: Jun 2004
Posts: 63
Post

Yes I beleive I am. If you look at my web page I toke a pic. of the manual and I'm installing it just like that.
As for the gasket I am using a Mr Gasket Ultra seal
part # 5861 and it to is about a 1/4" thick.
junbug is offline  
post #13 of 19 (permalink) Old Mar 20th, 05, 01:39 PM Thread Starter
 
Join Date: Jun 2004
Posts: 63
Post

The clearce between the oil pan to cross member is only about 1" I don't think it can get any closer then that but I could be wrong ?
junbug is offline  
post #14 of 19 (permalink) Old Mar 20th, 05, 01:42 PM Thread Starter
 
Join Date: Jun 2004
Posts: 63
Post

Yes I live real close to where detroit speed use to be and I seen them at the camaro super fest.
That wiper motor loos like the one in my pick !
junbug is offline  
post #15 of 19 (permalink) Old Mar 20th, 05, 02:20 PM
Gold Lifetime Member
Robert
 
Join Date: Oct 2000
Location: Simpsonville, SC
Posts: 3,359
Post

jackr is correct. I've had tall covers on the '67 when using roller rockers and had to loosen the wiper motor to get the cover off. The Edel' Elites have always appeared to be taller, not sure how much but that would explain your problem.

Robert

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
355ci 10:1, 64cc Edelbrocks, Comp Mag 280H, Performer RPM, 700r4 (2000 stall), 3.55 posi A/C PS PDB Hotchkis

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
369ci 10.3:1, 64cc Edelbrocks, Voodoo 276/284, Performer RPM, Holley 650DP ...T56 Magnum, 3.73 Moser 12 bolt
TC member #18
rojo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome