Turn signal cam bad? - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Feb 27th, 05, 07:11 AM Thread Starter
 
Join Date: Jan 2005
Location: Louisiana
Posts: 24
Question

Ok, about 6 months ago I pulled my wheel down and replaced the turn signal cam.. I have been fighting with brake light and hazards for a while now because they have been failing intermiditally. Yesterday I pulled the wheel apart and was able to recreate the problem. I'm going to do my best to describe this so hang in there.. You have the cam turn switch and something it snaps into.. (not sure what its called) Anyway when I pull the top left section where the lever screws in of the switch away (oppistite the brass piece where the springs are) I have all lights again.. As soon as I snap it back into place where it belongs I lose the lights.. Not sure whats going on because It looks to me lights its all plastic.. As a test I made a spacer (ok it was a piece of cardboard ) to go between the cam switch and ?? and re-assembled, drove it for about an hour and had no problems.. Does anyone know why snapping the switch in properly will cause this? I'm thinking the switch is bad. Hope I explained this ok.

Thanks in advace, Joe..

1969 Coupe - 427, TH350, 12 bolt, Eaton Posi w\3:55 gears.. <br /><br />It's a love\hate relationship!!
69427 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome