Blown fuse - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old May 28th, 01, 12:27 PM Thread Starter
 
Join Date: May 2001
Location: Baltimore MD
Posts: 5
Post

I drive an 89 rs 305 5sp
The fuse next to the battery blows immediately upon installing it. The wire exiting the fuse is orange. I've checked all the orange wires at the fuse box and none are shorted. My car won't start without this fuse. Does anyone know where this wire goes?
Jack Hammer is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old May 29th, 01, 03:22 PM
 
Join Date: May 2001
Location: Staten Island, New York
Posts: 4
Post

Since it is an in-line fuse, it sounds like an after market install. It could be going to an electronic fuel pump. Are you sure you are putting a fuse of the proper amperage in?

I had the same problem (it was my electronic fuel pump) and I discover I was only putting a 15amp fuse in. I checked the fuel pump for the specs of the voltage and amps in, than I bumped it up to a 30amp fuse and haven't had a problem since.

Good Luck
RonnieLarge is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome