M.A.D. Enterprises still in business???? - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Feb 20th, 04, 06:39 AM Thread Starter
 
Join Date: Feb 2004
Posts: 14
Question

Greetings,

does any know if M.A.D. Enterprises is still in business or not. I have been calling them at (559) 539-7128 but no one answers.



Thanks,

Chris
Pildor is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Feb 21st, 04, 05:37 PM
 
Join Date: Feb 2004
Location: Baytown, Texas
Posts: 7
Cool

http://www.madelectrical.com/index.shtml
Don't know about the phone # but this is the web site.

Arlon
arlondale is offline  
post #3 of 5 (permalink) Old Feb 21st, 04, 06:47 PM
Senior Tech
 
Join Date: Apr 2003
Location: Allen, TX
Posts: 2,108
Post

Try during normal business hours, its a one man shop! Bought a bunch of stuff from them, great product..

1969 Camaro - GM 2003 Electron Blue
Beck Racing 383 cu in 465HP Engine - Sean Murphy Inductions Stage 2 Quadrajet
TCI Streetfighter 350 - 3.73:1 Posi 10 Bolt Rear - 12.6 sec qtr mile

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brian Lewis is offline  
 
post #4 of 5 (permalink) Old Feb 22nd, 04, 06:32 AM
Senior Tech
John
 
Join Date: Jan 2002
Location: Central Minnesota
Posts: 343
Post

That's an excellent website. Good info.

This is so much fun I can't believe it's legal.
69 Camaro- Fastsburn 385 crate, 200-4R
69 Chevelle SS 396 4 Speed

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Midlife Cruiser is offline  
post #5 of 5 (permalink) Old Feb 23rd, 04, 03:26 PM Thread Starter
 
Join Date: Feb 2004
Posts: 14
Angry

Greetings,

got a hold of Mark at M.A.D. Electrical today and ordered the New System Kit for my 1968 Camaro!

Thanks everyone!
[img]graemlins/hurray.gif[/img]
Pildor is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome