Friend's new gauge cluster. - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Oct 11th, 04, 06:25 AM Thread Starter
Gold Lifetime Member
Bruno
 
Join Date: Oct 2000
Location: Puerto Rico
Posts: 2,118
Angry

Here are some pics of the new gauge cluster I'm instaling on my friend's 67. Everything that can be bench tested was verified already. Just a bit worried about the fuel sender's condition, 'cause the fuel gauge never worked for my friend and it may decide to play a trick on me, but we'll see. The smallest LEDs I found, for turn signals & hi beam indicators, are a bit less than a 1/4", couldn't find smaller ones locally tho.
Nice piece, and it fits perfectly on the dash's opening. [img]graemlins/thumbsup.gif[/img]
back view
front view

"Our affair with Camaros is a life sentence without the possibility of parole".
ORENCH is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Oct 11th, 04, 02:46 PM
Senior Tech
Dave
 
Join Date: Jan 2000
Location: Burley, Idaho, USA
Posts: 496
Angry

Looks great..We need a pciture when it's installed in the car.
Black69 is offline  
post #3 of 6 (permalink) Old Oct 11th, 04, 03:09 PM Thread Starter
Gold Lifetime Member
Bruno
 
Join Date: Oct 2000
Location: Puerto Rico
Posts: 2,118
Post

No problem. [img]graemlins/thumbsup.gif[/img]

"Our affair with Camaros is a life sentence without the possibility of parole".
ORENCH is offline  
 
post #4 of 6 (permalink) Old Oct 21st, 04, 07:10 PM Thread Starter
Gold Lifetime Member
Bruno
 
Join Date: Oct 2000
Location: Puerto Rico
Posts: 2,118
Question

My suspicions were right, the fuel sender had to come out. Got here yesterday, from the US, and it worked OK. Now, the darn autometer speedometer doesn't move a bit. Removed the dash assy. and the speedometer cable(center) doesn't move at all, with the car running on stands. Didn't had time to check today, but the tranny is a 4 sp Muncie. Is there something that might be missing inside that area? Like a pinion or something? I'll check this weekend, but if there're some hints, it'll be appreciated. I got to get rid of this car, it's taking me too much time, better spent cleaning mine. J/K, I want my friend's car performing as it was my car. [img]graemlins/thumbsup.gif[/img]

"Our affair with Camaros is a life sentence without the possibility of parole".
ORENCH is offline  
post #5 of 6 (permalink) Old Oct 22nd, 04, 07:56 AM
 
Join Date: Jan 2002
Posts: 395
Post

Pull the "bullet" (the thing the speedo cable screws onto the trans)from the side of the Muncie (one small bolt and a flat bracket holding it in place, then just pull on the case). When the bullet comes out there should be a plastic pinion gear that comes out with it. When the trans spins, that plastc gear spins and turns the speedo cable. The gear may be missing or broken/worn out, so its not turning when the trans turns.

I bought a rebuilt muncie and hooked up my speedo etc only to find out the shop never put a speedo gear in the trans. Its kind of a pian to get to the area once the trans is in the car, but its not that bad.
DRJDVM is offline  
post #6 of 6 (permalink) Old Oct 22nd, 04, 01:11 PM Thread Starter
Gold Lifetime Member
Bruno
 
Join Date: Oct 2000
Location: Puerto Rico
Posts: 2,118
Angry

Thanks, I'll check that. [img]graemlins/thumbsup.gif[/img]

"Our affair with Camaros is a life sentence without the possibility of parole".
ORENCH is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome