What bulb# for heater controls on a 69 - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old May 21st, 18, 11:45 AM Thread Starter
Gold Lifetime Member
Fred
 
77thor's Avatar
 
Join Date: Jun 2005
Location: Milwaukee, WI USA
Posts: 2,158
What bulb# for heater controls on a 69

After looking at the dash wiring harness, it appears as if the heater control light bulb is NOT a #194 bulb as the other dash bulbs... it is a twist-in bulb...

Does anybody know the bulb # (for a 1969)??

I've been referencing... https://www.superbrightleds.com/vehi...=514&year=1969
and suspect it is probably #1445, but I would like some verification before I place an order.

Thanks.

1969 Camaro SS, 350(NOM), M21, 12 Bolt Posi, 01B LOS Build
1977 Camaro, 350(LM1), M20, 10 Bolt Posi, Purchased New, (SOLD)
77thor is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old May 21st, 18, 01:28 PM
Senior Tech
Brian
 
Join Date: Dec 2014
Location: NE Ga
Posts: 841
Garage
Re: What bulb# for heater controls on a 69

I believe the bulb you are looking for is a 1895. Same as the glovebox IIRC....

69 Hugger Orange 396 M20 3:31
BRICO69 is offline  
post #3 of 4 (permalink) Old May 21st, 18, 03:26 PM
Senior Tech
Jeff
 
Join Date: Dec 2007
Location: Texas
Posts: 165
Garage
Re: What bulb# for heater controls on a 69

Quote:
Originally Posted by BRICO69 View Post
I believe the bulb you are looking for is a 1895. Same as the glovebox IIRC....
That is correct

Thanks,

Jeff


1968 Camaro
Chevy68 is offline  
 
post #4 of 4 (permalink) Old May 21st, 18, 05:07 PM Thread Starter
Gold Lifetime Member
Fred
 
77thor's Avatar
 
Join Date: Jun 2005
Location: Milwaukee, WI USA
Posts: 2,158
Re: What bulb# for heater controls on a 69

Ok. Thanks, guys.

FYI: I found out that the LED replacement is the same for both the #1445 and the #1895

1969 Camaro SS, 350(NOM), M21, 12 Bolt Posi, 01B LOS Build
1977 Camaro, 350(LM1), M20, 10 Bolt Posi, Purchased New, (SOLD)

Last edited by 77thor; May 21st, 18 at 05:41 PM.
77thor is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome