67 RS no headlights or tails - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old Jul 18th, 18, 04:25 PM Thread Starter
Apprentice
Brent
 
Join Date: May 2018
Location: Rhode Island
Posts: 23
67 RS no headlights or tails

Be patient with me this is my first Camaro and I didnít grow up with these cars so sometimes have dumb questions. TIA.

67 RS currently no headlights, tail lights or brake lamps. Headlight doors do not open. Turn signals work fine besides passenger front but that is a pre-existing issue prior to this.

Interior lights work fine by door switch so if my door is open both interior lights work. Hazards work as well. Gauges are these Dakota Digital(not a fan) ones and all work fine.

Is there a fuse in the driverís foot well that I need to check? Is there another fuse box I should be looking for?

Once again thank you trying to get a place to start. Worked fine a few days ago.


Sent from my iPhone using Tapatalk
Brent396 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old Jul 18th, 18, 05:29 PM
Senior Tech
Mike
 
Join Date: Mar 2017
Location: So Cal
Posts: 301
Garage
Re: 67 RS no headlights or tails

You will find the fuse box under the driver's side dash. Check there first. The fuses should be marked.
Old Dad's 67 is offline  
post #3 of 12 (permalink) Old Jul 18th, 18, 05:45 PM
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Re: 67 RS no headlights or tails

Grounds are terrible in first gens and are 90% of all electrical light gremlins. 67 RS factory headlights use boards and relays. These commonly cause issues with relays and limit switches needing replacement, tweaking etc.

So let us know are the RS headlights original to the car and still using the original boards or did the previous owner install them using newer technology.

Does pressing the bright switch on the floorboard turn the lights on or snap the doors open?

Brian


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
 
post #4 of 12 (permalink) Old Jul 18th, 18, 07:44 PM
Gold Lifetime Member
Roger
 
rogerh's Avatar
 
Join Date: Oct 2004
Location: Quincy, IL
Posts: 18,231
Re: 67 RS no headlights or tails

There is just one fuse panel on your car. Could be some inline fuses if anything was added over the last 51 years. The relay board that controls the headlight doors Brian talks about is under the left front fender by the windshield washer reservoir.

Roger

1967 Camaro SS/RS 350/295HP Coupe. First and only owner.
rogerh is offline  
post #5 of 12 (permalink) Old Jul 19th, 18, 03:45 AM Thread Starter
Apprentice
Brent
 
Join Date: May 2018
Location: Rhode Island
Posts: 23
Re: 67 RS no headlights or tails

Quote:
Originally Posted by Old Dad's 67 View Post
You will find the fuse box under the driver's side dash. Check there first. The fuses should be marked.


The box looks to be original and the labeling is well worn off. Do you have a print out of picture of which is which.

Also the wiring has been messed with over the years there is no doubt about that.

Would the headlight relays in the engine bay effect the taillamp and brake lamps?


Sent from my iPhone using Tapatalk
Brent396 is offline  
post #6 of 12 (permalink) Old Jul 19th, 18, 06:24 AM
Senior Tech
Camarodude67
 
Join Date: May 2005
Location: Hartford, CT
Posts: 2,284
Re: 67 RS no headlights or tails

You probably have a bad headlight switch. I have a lot of pics for 67 RS relays, wiring, etc I can text you...

Jeff G.
Hartford CT
camarodude67 is offline  
post #7 of 12 (permalink) Old Jul 19th, 18, 08:25 AM
Senior Tech
Mike
 
Join Date: Mar 2017
Location: So Cal
Posts: 301
Garage
Re: 67 RS no headlights or tails

There is a photo of the fuse box in this link...https://www.camaros.net/forums/19-el...ghts-help.html. When in doubt, grab a test light and check all your fuses. It looks like the bottom fuse is for tail and stop lamps.

On the RS headlight panel under the left front fender, there are 3 relays and a 10 amp circuit breaker. Check the circuit breaker first. All 4 components can be purchased for under $40. Here is info on how to troubleshoot https://retro-electro.net/FAQ67.html. I doubt this circuit panel has anything to do with the rear lights.

As camarodude67 suggested, you may have a bad headlight switch.
Old Dad's 67 is offline  
post #8 of 12 (permalink) Old Jul 19th, 18, 01:40 PM Thread Starter
Apprentice
Brent
 
Join Date: May 2018
Location: Rhode Island
Posts: 23
67 RS no headlights or tails

Quote:
Originally Posted by Old Dad's 67 View Post
There is a photo of the fuse box in this link...https://www.camaros.net/forums/19-el...ghts-help.html. When in doubt, grab a test light and check all your fuses. It looks like the bottom fuse is for tail and stop lamps.



On the RS headlight panel under the left front fender, there are 3 relays and a 10 amp circuit breaker. Check the circuit breaker first. All 4 components can be purchased for under $40. Here is info on how to troubleshoot https://retro-electro.net/FAQ67.html. I doubt this circuit panel has anything to do with the rear lights.



As camarodude67 suggested, you may have a bad headlight switch.


To update he original post. When I pull the headlight lever out to the parking light position the parking light comes on. Headlights do not.

Prior to this headlights came out in the parking lamp position.

So no headlights, brake lights, tail lights, no motorized RS headlight doors either.

Turn signals work as normal, parking lights work as normal, hazards normal, interior courtesy lights on when door is open.

Sent from my iPhone using Tapatalk
Brent396 is offline  
post #9 of 12 (permalink) Old Jul 19th, 18, 05:57 PM Thread Starter
Apprentice
Brent
 
Join Date: May 2018
Location: Rhode Island
Posts: 23
Re: 67 RS no headlights or tails

Quote:
Originally Posted by Old Dad's 67 View Post
There is a photo of the fuse box in this link...https://www.camaros.net/forums/19-el...ghts-help.html. When in doubt, grab a test light and check all your fuses. It looks like the bottom fuse is for tail and stop lamps.



On the RS headlight panel under the left front fender, there are 3 relays and a 10 amp circuit breaker. Check the circuit breaker first. All 4 components can be purchased for under $40. Here is info on how to troubleshoot https://retro-electro.net/FAQ67.html. I doubt this circuit panel has anything to do with the rear lights.



As camarodude67 suggested, you may have a bad headlight switch.



Removed this from the car. Should a 67 RS have a 7 or 8 PIN headlight switch?

Would the wrong switch account for before (when lights were working) having the headlights come on while the plunger was pulled only to the parking light position?




Sent from my iPhone using Tapatalk
Brent396 is offline  
post #10 of 12 (permalink) Old Jul 19th, 18, 06:31 PM
Senior Tech
Mike
 
Join Date: Mar 2017
Location: So Cal
Posts: 301
Garage
Re: 67 RS no headlights or tails

I checked my old one. It looks just like yours...8-Pin. Here's a link for the photo. https://shop.advanceautoparts.com/p/...415p/5970857-P
Old Dad's 67 is offline  
post #11 of 12 (permalink) Old Jul 19th, 18, 07:35 PM Thread Starter
Apprentice
Brent
 
Join Date: May 2018
Location: Rhode Island
Posts: 23
Re: 67 RS no headlights or tails

Quote:
Originally Posted by Old Dad's 67 View Post
I checked my old one. It looks just like yours...8-Pin. Here's a link for the photo. https://shop.advanceautoparts.com/p/...415p/5970857-P


I tested continuity and it checked fine. Also tests the dimmer worked perfectly (moot point since I have Dakota digital gauges)

I am going to pickup a new floor dimmer switch too while I am at the parts store just incase.

I feel a brand new full harness is in order this winter get rid of the 50 year old harness.


Sent from my iPhone using Tapatalk
Brent396 is offline  
post #12 of 12 (permalink) Old Jul 22nd, 18, 01:45 PM Thread Starter
Apprentice
Brent
 
Join Date: May 2018
Location: Rhode Island
Posts: 23
67 RS no headlights or tails



Bought a test light. Here is a picture of my fuse box. The bottom two glass fuses are good. Third from the bottom is missing. The top four glass tube fuses have no power at all on either side of the fuse.

Turned the key to ON and rechecked. The top three all have power. The 4th one down or up doesnít have any power at all. The empty one has power on the left obviously no fuse to go through. Bottom two checked good again.

I have a new headlight switch shipping as well. Does anyone know what my empty spot does and also what the one that is completely dead does?

Sent from my iPhone using Tapatalk

Last edited by Brent396; Jul 22nd, 18 at 02:41 PM.
Brent396 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome