Camaro78 - Igntion Problems - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old May 3rd, 05, 03:39 PM Thread Starter
 
Join Date: May 2005
Posts: 1
Camaro78 - Igntion Problems

Hi.I write from Poland. I'm owner of 78Camaro, 305, with Accel 49106E DualPoints Distributor and Accel 8140C Coil.
The problem has started when by my mistake i leaved the car switched on [ but engine was stopped ]. Probably points were connected what caused coil to blow [ it was about 160C degrees hot ]. When it became cool [ after 20minutes car started but died after several minutes... ] Several attempts to repair failed.

I've replaced Coil and Points. Engine has started and was running for 5 mins, then died. Coil was hot [ about 50-60C Degrees ].

What should/could i do to repair that problem?
I disassembled everything and after metering i have such readouts:

1. Coil primary - 1.8Ohm, secondary - 9.4KOhm,
2. Points are cleared out and looks good [ no burning spots ],
3. Condenser metering didnt show anything [ no resistance at all - CAUSE of FAILURE? ]
4. HV Wire from Coil to Distributor shows 7.4KOhm [weird... 1ft long] and all others [ from distributor to spark plugs show 0.5-0.8KOhm ]
5. I have no balance resistor [ Does the 2.5Ohm would be ok? ]

Thanks
Kamil
administry is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Two of My Main Problems... xprow Tech 2002 2 Jul 3rd, 02 09:10 AM
Power Window Problems brichead Electrical & Wiring 2 May 13th, 02 08:05 PM
Tuning problems 79Camaro Tech 2000 5 Apr 6th, 01 08:30 PM
MSD PROBLEMS RAY NORLIN Troubleshooting 3 Oct 9th, 00 03:40 PM
intercooler problems with procharger Chad Byers Troubleshooting 1 Jun 3rd, 99 08:57 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome