2001 Z28 ignition switch/security system malfunction - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Sep 20th, 05, 06:23 PM Thread Starter
 
Join Date: Sep 2005
Posts: 2
Question 2001 Z28 ignition switch/security system malfunction

I have a 2001 Z 28 with an annoying intermittent electrical problem. As I turn the ignition key from off to run to start I get the following: at the run postion all the dash warning lights come on; after a few seconds all the dash warning lights/function lights go off except for the security light which stays on. At the start position I get absolutely nothing. The starter doesn't crank and I get no solenoid sounds. Simply dead. The headlights and electric windows work, so the battery is fully charged. After this happens and I turn the key to "off", all the needles in all the gages snap to full scale then back to normal. This is with the key off and removed from the ignition switch! This model year has that little diode-like sensor in the ignition key. I am wondering if this problem could be A)a broken ignition switch, or B)a malfunction of the security system. With regard to the latter, does anyone know if the car won't let you start it if it does not recognize the key diode?
45Auto is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Sep 21st, 05, 05:08 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,853
Garage
Re: 2001 Z28 ignition switch/security system malfunction

Read the Owner's Manual, it should state to start the engine with the same key min of 3 minutes waiting time from the first attempt. VATS(? for 2001) is doing its job.

You will probably have to have the ignition key tumbler replaced and it comes with a new key. See the dealer for replacement along with vehicle registration and OE key.

Oh, Welcome to the Club! Newbies buy first round...........From where?

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.

Last edited by Everett#2390; Sep 21st, 05 at 05:09 AM. Reason: Added Welcome
Everett#2390 is offline  
post #3 of 4 (permalink) Old Sep 21st, 05, 04:53 PM Thread Starter
 
Join Date: Sep 2005
Posts: 2
Re: 2001 Z28 ignition switch/security system malfunction

So, can I check the key resistor with an ohm meter and then get GM to tell me what the real value for my key should be? That way I should be able to tell if the key resistance has changed. If it is O.K. then the problem may lie with the ignition switch key resistor sensor. Can I use the OBD system to check for VATS or BCM malfunction? The security light does not stay on, so I wonder if the computor actually has registered a problem. I have also seen a number of reports about VATS bypass resistor kits. Can I bypass the VATS without screwing up something else?
45Auto is offline  
 
post #4 of 4 (permalink) Old Sep 22nd, 05, 08:19 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,853
Garage
Re: 2001 Z28 ignition switch/security system malfunction

You can measure the resistance using a DMM, or, give key to dealer and the parts man/woman can tell you if it has changed in value. A matching resistor is in the VATS module, so it may be the VATS key socket in the switch not reading correctly.

The "leaves" or socket are very thin metal and they do lose their elasticity and sometimes do not "feel" the key, hence, starter will not engage until waiting after three minutes to attempt to start again. A replacement socket is with the tumbler assembly underneath the steering wheel and lock plate, so they have to be removed.

I don't believe a PCM will show trouble code, I've never used one, so I'm out to lunch on this event.

Another problem may be the starter relay having a burnt set of contacts. Replacement of same would cure this problem.

VATS sub kits can be gotten. Others know of addresses of businesses selling same, or Google it.
Everett#2390 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ignition system MSD or Crane ? Markus Engine 1 Mar 24th, 03 03:31 AM
Ignition System jjstpd Engine 3 Jan 23rd, 03 05:29 AM
Ignitor II Ignition system Johnny in AZ Performance 9 Oct 30th, 02 08:07 AM
Ignition malfunction Cultch Troubleshooting 1 Aug 6th, 02 01:56 PM
ignition system upgrades??? purplecamarov6 Performance 4 Nov 26th, 01 11:09 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome