still no fire day two 87 2.8 camaro - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jan 11th, 06, 03:26 PM Thread Starter
 
Join Date: Jan 2006
Posts: 8
still no fire day two 87 2.8 camaro

I have changed the module, coil, cap, rotor.

The coil has power to it and power is going to the bottom of the distrib.

It still seems odd that I dont get any Oil, Alt, Temp lights on the dash when I first turn on the key.

the buzzer sounds and I do get a brake and check eng light on the lower dash

Would this modle have some type of shut off for low oil press.

Could it be in the ing switch?

Thanks for your help
IBNFECPO is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jan 12th, 06, 03:07 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,661
Garage
Re: still no fire day two 87 2.8 camaro

Things to check:
1. Power to dist when in the start position?
2. Fuel pump working? When IGN sw goes to IGN, you should hear the fuel pump running for 2 seconds, ECM controlled. Fuel relay is up by the drvr hood hinge.
3. Broken fusible link at the starter solenoid terminal.
4. Oil pressure sending unit broken? There is a set of extra terminals to power fuel pump relay when oil pressure gets above 15 PSI, if the f/pump relay doesn't run under normal conditions.
5. I don't think it could be the ign switch, but one would never knows.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden … enjoy your next chapter.
Everett#2390 is offline  
post #3 of 4 (permalink) Old Jan 13th, 06, 08:34 AM
Senior Tech
Mark
 
Join Date: Mar 2001
Location: Janesville, WI
Posts: 618
Re: still no fire day two 87 2.8 camaro

Motors need 3 things to run.... GAS,SPARK,AIR.... You can check the spark by placing a timing light on the spark plug wire and attempting to start it. The light should blink a couple of times a sec.. Gas metering is controled by the computer.. can you check to see if it has any code faults..? is the thottle body getting gas.. it will usually puddle a bit on the throttle butterflys.

Mark
Long Gone: 1984 Z28, 1989 RS
Current : 1967 Coupe w/350, 2010 2SS

My Photobucket >>
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dragon0123 is offline  
 
post #4 of 4 (permalink) Old Jan 14th, 06, 03:12 PM Thread Starter
 
Join Date: Jan 2006
Posts: 8
Re: fire fire fire day four 87 2.8 camaro

I would like to thank all of you for your help.

I changed the distrib and she fired right up.

Im sure it was the pick up coil because it was the only thig I had not changed.

It seems like water collects really easy under the distrib cap.

The whole assy was severly corr when I fist looked at it.

Again thaks for your help.
IBNFECPO is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome