MSD ignition wiring - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old Feb 3rd, 06, 06:06 PM Thread Starter
 
Join Date: Dec 2004
Posts: 421
MSD ignition wiring

I have an MSD unit and also purchased a new engine compartment wire harness for american auto wire...They set the harness up to wire to the MSD unit where the wire from the MSD unit goes to the keyed source, they gave me two wires a pink and yellow. In talking with them they said to connect the pink and yellow wires together and then connect to the red keyed wire from the MSD unit. This worked perfectly until today when I installed my gauge cluster (speedometer and fuel gauges) into the dash. When I plug the plug into the back of the gauges, I loose the keyed source or in otherwords I can not turn the motor off. I have to disconnect the wires. When the plug into the back of the gauges is not plugged in, the motor will turn on and off like it is suppose to with the key.

Does anyone have this setup or maybe know what could be causing this? I do have the plug, plugged in correctly, I have checked that 3 or 4 times...
Liveinaz is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old Feb 3rd, 06, 06:22 PM
wdf
 
Join Date: Jan 2006
Posts: 65
Re: MSD ignition wiring

you have a back feed install a diode in series to the guages power plug
wdf is offline  
post #3 of 9 (permalink) Old Feb 3rd, 06, 06:28 PM Thread Starter
 
Join Date: Dec 2004
Posts: 421
Re: MSD ignition wiring

Does this need to be on the gauges plug or on the new wires to the MSD? Where can I get a diode from? How would I install it and to which wire?
Liveinaz is offline  
 
post #4 of 9 (permalink) Old Feb 4th, 06, 06:36 PM
wdf
 
Join Date: Jan 2006
Posts: 65
Re: MSD ignition wiring

Quote:
Originally Posted by Liveinaz
Does this need to be on the gauges plug or on the new wires to the MSD? Where can I get a diode from? How would I install it and to which wire?
50 volt diode 10 watt available at radio shack
what color wires do you have in guages plug?
wire in series to guages plug wire that loses power when key turns off (plug not connected) note- observe correct polarity
wdf is offline  
post #5 of 9 (permalink) Old Feb 4th, 06, 06:50 PM Thread Starter
 
Join Date: Dec 2004
Posts: 421
Re: MSD ignition wiring

There are 12 wire slots on the although all are not used. 1 - 6 on top and 7 - 12 on bottom...Here is the colors connected to each

1 Brown
2 Green (double wires)
3 Grey
4 nothing connected
5 nothing connected
6 nothing connected
7 Red
8 Dark blue
9 Light blue
10 Light brown
11 Dark brown
12 Dark blue

When you say wire in series, I would assume you mean to splice this into the wire? Also in which direction would the polarity go?

Thanks for your help.
Liveinaz is offline  
post #6 of 9 (permalink) Old Feb 4th, 06, 08:14 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: MSD ignition wiring

check this off the msd site: http://www.msdignition.com/1troub1.htm#runon





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #7 of 9 (permalink) Old Feb 5th, 06, 09:01 AM Thread Starter
 
Join Date: Dec 2004
Posts: 421
Re: MSD ignition wiring

That is what I need...it says that it should connect to the brown wire from the alternator. I do have a brown wire coming from my alternator plug so I would guess that this is where the diode should be connected. there are two wires that plug into the alternator. One is red and the other is brown...does anyone know what these wires are used for or their function in the circuit? I know there is a thicker red wire too, but I am referring to the two wires that are plugged into the alternator with an internal regulator...
Liveinaz is offline  
post #8 of 9 (permalink) Old Feb 5th, 06, 09:20 AM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: MSD ignition wiring

The color codes are different than stock because of the internal reg alternator, but the brown one feeds the gen light, that's the one that gets the diode. The red one is the "Remote voltage sense" line and should connect in the main splice of horn relay.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #9 of 9 (permalink) Old Feb 8th, 06, 05:25 PM Thread Starter
 
Join Date: Dec 2004
Posts: 421
Re: MSD ignition wiring

I added the diode to the brown wire as indicated, however my gen light stays lite up when the motor is running...I am wondering if it could have anything to do with adding the diode? I know the diode is installed correctly as far as direction, and the car turns on and off with the key again...Any ideas why the gen light on the dash would stay on?
Liveinaz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome