Lobeam problem with 91 camaro - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Feb 4th, 06, 10:51 AM Thread Starter
 
Join Date: Feb 2006
Posts: 1
Lobeam problem with 91 camaro

My hibeams are stuck when lights are on: no low beams. The flashing lights do not work. The turn lights do work. Help, I'm getting hibeam flashes from oncoming cars at night.

Also, the radio receives noise interferences on an
occasional, but constant basis at the lower radio frequencies.
JHBCFA is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Feb 4th, 06, 12:00 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,657
Garage
Re: Lobeam problem with 91 camaro

When you push/pull the combo switch lever, its pushing /pulling a rod down the steering column to the HI/LO beam switch. You should "feel" the detent when you do this selection.

If not, then the switch may be broken or the rod came out of place. The switch is located on driver side of column on top somewhere close to the column clamp.

You might be able to remove the bottom finisher and feel up there for the switch and be able to manually place the switch into LO beam.

The hazard flasher may be broken needing replacement.

Radio noise can smothered with a filter from Radio Shack. If the noise increases with engine rpm, alternator noise coming through. Could be a corroded ground on the radio unit itself. Spark plug noise could be from bad plug wires, loud ticks through the speakers.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome