Turn signal Socket for a 68 - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Feb 20th, 06, 04:06 PM Thread Starter
 
Join Date: Jan 2006
Posts: 36
Turn signal Socket for a 68

I am installing a turn signal socket in my 69 camaro. I am having trouble getting the second filament (the brake light) to come on. The car came with the wiring and socket for only the drivers side. On this side, both filaments light when the head lights are on and I hit the brakes. On the the other side, there are two hot wires. With my test light i identified the running light wire and the brake wire. howerever, the brake light filament does not come on. i tried it in the good socket and it works, i also tried rotating the build but nothing. only the dim filament comes on.

i am not sure if i am grounding this correctly. i assume one wire is is for the brake lights and the other is for the running lights. is this the correct socket? how do i ground it?

any other suggestions are appreciated. b/t/w, i assume this socket also handles the turn signals, but none of the signals work so that is a project for another day

thanks

The part number is 85865 made by conduct tite. the link is below.

http://www.dormanproducts.com/cgi-bi...LL&vTime=68351
rodutah is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Feb 20th, 06, 07:57 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Turn signal Socket for a 68

The socket grounds thru it's mounting. There are 2 lil metal things on the lip that goes into the tailight, that's the ground.

Without a proper ground, you're beating a dead horse. The tail lights housings have to be bolted to the body (I use star washers under 2 of the nuts to make sure) and the back of the housing where the bulb plugs in needs to be clean.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #3 of 3 (permalink) Old Feb 21st, 06, 05:35 AM Thread Starter
 
Join Date: Jan 2006
Posts: 36
Re: Turn signal Socket for a 68

Thanks Jim much appreciated
rodutah is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome