no electrical - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Apr 14th, 06, 12:39 PM Thread Starter
 
Join Date: Apr 2006
Posts: 6
no electrical

i have a 91 305 tbi. i have no power to my fuel pump. i replaced the fuel relay switch and i still have spark to the plugs. any hints?
91 5stbi is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Apr 14th, 06, 02:11 PM
Senior Tech
 
Join Date: Jun 2005
Location: Sunny So. Cal
Posts: 3,064
Re: no electrical

Check the Fuel pump fuse and also your connection to the pump at the connector near the tank.

67 RS Camaro 327/ 350 Holley 650cfm > Edelbrock Performer Intake > Pertronix Ignition > Accel Super Stock Coil and Wires > Hedman Hedders > Hotchkis Performance Springs > 15" Rallys all around


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Camaro buds until the end!!!
Camaro Dave is offline  
post #3 of 4 (permalink) Old Apr 14th, 06, 03:24 PM Thread Starter
 
Join Date: Apr 2006
Posts: 6
Re: no electrical

fuse is good, so is the connection at the tank. where exactly does the power come from before it hits the relay switch? from the starter solenoid or some other connection i dont know about?
91 5stbi is offline  
 
post #4 of 4 (permalink) Old Apr 14th, 06, 03:36 PM
Senior Tech
Steps
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,316
Re: no electrical

Use a spare battery or starter unit, or run a lonf wire, to the power feed on the pump.

it will either click and then do nothing ....replace it (i think these run all the time with a bypass up front??)
or
Do nothing. ...replace
or click then run, u will be able to feel it vibrating or hear it running....check ciruits.

My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie Mod in Electrical! JimM Electrical & Wiring 19 Jan 7th, 06 10:28 AM
need electrical help for keyswitch power bl1work Electrical & Wiring 3 Dec 29th, 05 06:12 PM
67 camaro electrical questions myoramac Electrical & Wiring 1 Dec 23rd, 05 10:57 PM
My Electrical Upgrades Brian Lewis Electrical & Wiring 2 Oct 25th, 03 05:46 PM
Electrical Drain 67 Camaro RS Electrical & Wiring 5 Jun 26th, 03 03:11 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome