electrical turn singal problems - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Apr 24th, 06, 10:19 PM Thread Starter
 
Join Date: Apr 2006
Posts: 2
Question electrical turn singal problems

I tryed to figure out this problem and failed badly, the problem on my 86 camaro is when you use the turn signal left or right all lights try to blink at the same time. also when I turn on the light switch and turn the turn signal with key in the off position the insterment warnings light cluster will come on until you turn the key in the on position. I change the turn signal switch with a new one but did not help, instead it created a different problem, whats going on? and how can I fix this problem Thanks for reading this message Tom.
86 red camaro is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Apr 27th, 06, 07:46 PM
Gold Lifetime Member
Kevin
 
SixtyAte's Avatar
 
Join Date: May 2005
Location: S. Eastern Massachusetts
Posts: 5,582
Re: electrical turn singal problems

Sorry,
You have a major problem somewhere with the wiring. Are the 4 way /emergency flashers on?
Kev
SixtyAte is offline  
post #3 of 4 (permalink) Old Apr 27th, 06, 09:59 PM Thread Starter
 
Join Date: Apr 2006
Posts: 2
Re: electrical turn singal problems

No, the four way flashers work the way suppsoe to some one said there might power back feeding some where.
86 red camaro is offline  
 
post #4 of 4 (permalink) Old Apr 27th, 06, 10:37 PM
Senior Tech
Steps
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,321
Re: electrical turn singal problems

Bad earth ?

My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
No right rear turn signal or hazard Obxhokie Electrical & Wiring 6 Jul 9th, 06 06:00 PM
electrical problems 70camarro Electrical & Wiring 5 Apr 9th, 06 07:37 PM
starting problems DL Engine 4 Jul 13th, 04 02:31 PM
Arrrrrrrggggggggggggg....electrical problems..engine wont start.. kel Troubleshooting 11 Sep 6th, 01 04:05 PM
BRAKE lights OUT when USING THE TURN SIGNALS KED67 Electrical & Wiring 5 Jun 26th, 01 03:40 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome