Loss of power feed - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Apr 25th, 06, 10:43 AM Thread Starter
 
Join Date: Apr 2006
Posts: 25
Loss of power feed

when ignition or headlights turned on i lose the power feed from the horn relay to the fuse block any ideas? thanks.
tonyb is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Apr 25th, 06, 12:56 PM
Senior Tech
 
Join Date: Jul 2001
Location: Pontiac IL
Posts: 453
Send a message via AIM to undee72Z
Re: Loss of power feed

Could be the fusible link about burned in two, loose or corroded connections at horn relay or connections at firewall bulkhead.


Greg U

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
undee72Z is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
79 power window question SirKnite Electrical & Wiring 0 Jul 28th, 05 04:10 PM
68 power steering burner Brakes, Suspension & Steering 2 Apr 2nd, 04 09:47 AM
Supercharger power steering problem need A-Body Procharged69 Tech 2003 5 Oct 22nd, 03 10:44 AM
Power Loss MaxR Troubleshooting 1 Feb 2nd, 03 08:42 PM
Loss o Power under 3,000 rpms Ay96SS Troubleshooting 2 Jun 21st, 02 08:14 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome