New voltage regulator - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old May 5th, 06, 12:06 PM Thread Starter
 
Join Date: Oct 2005
Posts: 40
New voltage regulator

I just put a new Voltage regulator on my '69 Camaro, hooked the three poss. cables back on the battery, started it up GEN light went out (yeah), but when I turn the ignition off, it continues to run, and the GEN light comes back on. The car stops running after I disconect the hot wire going to the MSD (I think) box. Any ideas????
Dan 69 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old May 5th, 06, 01:53 PM
Senior Tech
 
Join Date: Jul 2001
Location: Pontiac IL
Posts: 453
Send a message via AIM to undee72Z
Re: New voltage regulator

Quote:
Originally Posted by Got Taken
I just put a new Voltage regulator on my '69 Camaro, hooked the three poss. cables back on the battery, started it up GEN light went out (yeah), but when I turn the ignition off, it continues to run, and the GEN light comes back on. The car stops running after I disconect the hot wire going to the MSD (I think) box. Any ideas????
MSD6al? You need a diode. It is backfeeding through the GEN lamp, keeping the car running. See pg 8 of the installation instuctions.

Greg U

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
undee72Z is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Charging system, external regulator JimM Electrical & Wiring 14 Apr 7th, 19 06:43 PM
Mounting / Grounding Voltage Regulator 3rail Electrical & Wiring 3 Apr 24th, 06 01:29 AM
weird happenings going on with voltage regulator hotrodz/28 Electrical & Wiring 4 Apr 12th, 06 10:04 PM
No voltage regulator Omnipotent Electrical & Wiring 4 Mar 20th, 06 07:06 AM
Voltage Regulator problem paulm Electrical & Wiring 2 May 21st, 03 08:05 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome