Turn Signals - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old May 15th, 06, 05:29 PM Thread Starter
 
Join Date: Mar 2006
Posts: 4
Turn Signals

I have a 69, my right turn signal will not flash, I have changed all the bulbs . Could this be a bad flasher ? The left side is working fine. Any suggestions ?
CPS57 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old May 15th, 06, 06:57 PM
Gold Lifetime Member
Kevin
 
SixtyAte's Avatar
 
Join Date: May 2005
Location: S. Eastern Massachusetts
Posts: 5,536
Re: Turn Signals

Bad flasher or bad ground on the sockets on that side. Try the flasher first and if that doesn't solve it, with the directional set to blink, use a test light or wire to the body ground and to the metal bulb edge and see if it blinks.

Kev
SixtyAte is offline  
post #3 of 5 (permalink) Old May 15th, 06, 08:36 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Turn Signals

I'd guess bad ground.
Check your tail lights with the turn signal AND the headlights on, see if you see anything wierd.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
 
post #4 of 5 (permalink) Old May 15th, 06, 11:29 PM
Senior Tech
 
Join Date: Jun 2005
Location: Sunny So. Cal
Posts: 3,064
Re: Turn Signals

I would think that the problem would be in the turn signal switch, wiring or as stated a bad ground. I doubt it is the flasher, because the left side would not work either.

67 RS Camaro 327/ 350 Holley 650cfm > Edelbrock Performer Intake > Pertronix Ignition > Accel Super Stock Coil and Wires > Hedman Hedders > Hotchkis Performance Springs > 15" Rallys all around


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Camaro buds until the end!!!
Camaro Dave is offline  
post #5 of 5 (permalink) Old May 26th, 06, 04:36 AM
 
Join Date: May 2006
Posts: 7
Exclamation Re: Turn Signals

I've changed many Flashers (#552) to correct a problem isolated to one side. Hope this helps.
Mr. Duece is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
68 Turn Signals rodutah Electrical & Wiring 7 Mar 12th, 06 06:19 PM
RS brake lights and turn signals Chris1111 Electrical & Wiring 10 Oct 13th, 05 11:35 PM
Littering and Turn Signals TJS69 Bench Racing 12 Sep 7th, 05 05:44 PM
turn signals not working kool Electrical & Wiring 1 Apr 18th, 05 05:51 PM
BRAKE lights OUT when USING THE TURN SIGNALS KED67 Electrical & Wiring 5 Jun 26th, 01 04:40 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome