So I was out driving the other day . . . - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old May 22nd, 06, 11:53 PM Thread Starter
Tech Team
 
Join Date: Mar 2006
Posts: 46
So I was out driving the other day . . .

I was out driving yesterday, getting my new custom "68GREAT" plate at the DMV, and at one point had to merge left. I gave the guy to the back left good warning and had my blinker on for a few hundred yards, but the guy would not back off. Finally I down shifted and hit the brakes a little and let him go by, wondering what was his damn hurry and putting my arm out to tell him to go ahead. I was kind of upset, but as I pulled alongside him at the light, he waited for me with an open passenger window and told me that when I had been trying to get over, my left turn signal triggered both turn signals. I had been pissed off at him and he was just trying to help.

Before I go screwing around with the wiring myself, has anyone heard of such a thing, and moreover, fixed it? After some testing, I have found that when the right turn signal is activated, only the right front indicator lights up, and nothing happens in back. With the left turn signal, both signals light up and flash. Inside on the gauges, the right turn arrow flashes correctly, but the left turn arrow stays solid. This is new territory for me and I dread electrical problems.

Thanks for any help, and if anyone has any step by step advice on what to try first second and so on to isolate the problem, that would be much appreciated.

Thanks,

Mike
mikey1968 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old May 23rd, 06, 12:43 AM
Senior Tech
 
Join Date: Jul 2001
Location: Pontiac IL
Posts: 453
Send a message via AIM to undee72Z
Re: So I was out driving the other day . . .

Do you have brake or running lights on the right rear? Could be the bulb or the ground.

Greg U

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
undee72Z is offline  
post #3 of 6 (permalink) Old May 23rd, 06, 06:06 AM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: So I was out driving the other day . . .

I'd suggest the right tail light assembly is not grounding to the tailpan. Pick up a few 1/4" external star washers at your local hardware store. Put one under at leat 2 of the nuts in each tail light assembly. Also check the bulb sockets and make sure the lil tabs are grounding properly, could just need a lil scotch brite rubbing on the terminals and the hole where the socket plugs in.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
 
post #4 of 6 (permalink) Old May 23rd, 06, 10:25 AM Thread Starter
Tech Team
 
Join Date: Mar 2006
Posts: 46
Re: So I was out driving the other day . . .

I will look into that. Yes, it does seem the back right bulb has been loose against the metal grounding. I'll see what I can do and if it changes the problem. Thank you both for the suggestions!

-Mike
mikey1968 is offline  
post #5 of 6 (permalink) Old May 23rd, 06, 04:12 PM Thread Starter
Tech Team
 
Join Date: Mar 2006
Posts: 46
Re: So I was out driving the other day . . .

Checked the light housing and it is grounded (brake lights and emergency work just fine.)

Is there a relay or control switch that determines where the signal goes? It all seemed to go out at once. Again, right front turn indicator still works, as do brake lights. Help!

-Mike
mikey1968 is offline  
post #6 of 6 (permalink) Old May 23rd, 06, 11:50 PM
Senior Tech
 
Join Date: Jun 2005
Location: Sunny So. Cal
Posts: 3,064
Re: So I was out driving the other day . . .

If the grounds are good, and the bulbs are working.....the problem might be the switch itself. Do you get a decent "Click" sound when you activate the turn signals from right to left? Grab a test light and turn on the left turn signal. Check the turn signal harness by poking the test light into the harness and see if the test light will blink when you touch the left turn signal wire of the harness. If you have two blinking wires, then the switch is the culprit.

67 RS Camaro 327/ 350 Holley 650cfm > Edelbrock Performer Intake > Pertronix Ignition > Accel Super Stock Coil and Wires > Hedman Hedders > Hotchkis Performance Springs > 15" Rallys all around


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Camaro buds until the end!!!
Camaro Dave is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Do you think about your car project all day like me, or am I just eaten up ray moore Camaro Tech 29 Jan 7th, 06 12:58 PM
State Fair Fbody Day 10/15/05 Registration/Release Info!! cytruffle Team Camaro Cruiz-Ins 1 Aug 20th, 05 08:12 PM
July 30th E-town race brings 70 cars to the day! SUPERGONZO Team Camaro Cruiz-Ins 0 Jul 31st, 05 03:25 PM
67 driving lights/headlights gasmoney Electrical & Wiring 0 Apr 9th, 03 10:49 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome