Any ideas? - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jun 7th, 06, 11:43 AM Thread Starter
 
Join Date: Sep 2002
Posts: 21
Any ideas?

Misfires at low rpm's. From idle to about 30 mph.

I have been having trouble with ignition modules blowing. When the last one blew I tried an Accel. It started misfiring bad. So, I changed the plugs, wires, cap & rotor. No difference. I changed the module back to a standard brand. Better but still misfiring. I then checked the timing which I found to be way off. Fixed that. Runs a bit better but it's STILL misfiring. It also takes a long time to keep it running after a cold start. I'm thinking I may put in a new distributor. Any other ideas before I go and spend the money?
MJwrabbit is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jun 7th, 06, 12:26 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 32,201
Garage
Re: Any ideas?

Use plenty of dielectric grease supplied with the module between the module and the dist body.

Only item you haven't changed is the coil.

If you have cast exhaust manifolds, it'll be hard to use a temp gun and measure exhaust temp to see/feel which cylinder is not firing. If you do have manifolds, you can 'shoot' the spark plugs for temps and see which ones are not firing.

Lean fuel to cylinders can do this also, or a vacuum leak. Vacuum gauge registers?

Another brand of spark plugs?

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden … enjoy your next chapter.
Everett#2390 is offline  
post #3 of 4 (permalink) Old Jun 7th, 06, 01:36 PM
Senior Tech
Mark
 
Join Date: Feb 2005
Location: Georgetown, TX
Posts: 335
Garage
Re: Any ideas?

Could be a number of things. I'd verify that the firing order is correct, then verify that the distributor is being supplied with 12 volts when the car is running. If the distributor is being supplied power through the resistance wire, it could only be receiving 8 volts or so when the car is running. This could also causing the ignition modules to go bad. If that checks out OK, then I'd look for a vacuum leak somewhere, like an open vacuum port on the carb or possibly a leaking/blown vacuum advance module on the distributor.

Hope this helps!!
LukeWarm is offline  
 
post #4 of 4 (permalink) Old Jun 7th, 06, 02:56 PM Thread Starter
 
Join Date: Sep 2002
Posts: 21
Re: Any ideas?

Thank you, these have given me a few avenues to explore. I did do a Vacuum test as well as a compression test and all seems well.
MJwrabbit is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for room ideas hideaway Bench Racing 3 Feb 22nd, 06 07:11 AM
I need ideas for interior remod. Jonjon Interiors 3 Oct 26th, 05 11:59 AM
Rolling sound from rear when making wide & long right turns... any ideas? 1967rsss350 Troubleshooting 1 Oct 5th, 05 12:26 PM
New small block ideas?? MStennes Performance 54 Sep 17th, 05 05:50 AM
Long term storage ideas (locations) JHunter Bench Racing 8 Apr 6th, 05 09:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome