Brake light problem - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Jun 23rd, 06, 09:05 PM Thread Starter
Senior Tech
Kevin
 
Join Date: Mar 2001
Location: LaPorte, Indiana
Posts: 308
Garage
Brake light problem

Having trouble with my brake lights. Kinda a weird situation, but the lights work when I have the parking lights on and when the turn signal is on or the hazards. But when I hit the brakes the drivers side brakes light do not work. The passenger side lights work fine I have changed the bulbs in that side, but that did not help. I got it to work once, but now it doesnt. Could it be a ground? If so, where is it ground? Would if have to do something with the turn signal wire harness that runs done the steering column? The reason I ask is because I have to manually turn the signal off. I just don't get it when it is only the drivers side I am having a problem with, and its only when I hit the brakes?

Any suggestions?

Sixty-Seven rs

67 Camaro rs/350 HO(est. 401hp)/4L80E/8.5" 10 bolt 3.73
Sixty-Seven rs is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Jun 23rd, 06, 09:37 PM
Senior Tech
Steps
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,319
Re: Brake light problem

A ground, there is a black wire that goes into the side of the buld holder, clean connection up and solder the wire to the connector.
OR around the trunk catch is a black wire that is earthed there, clean that up.

My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline  
post #3 of 3 (permalink) Old Jun 24th, 06, 06:25 AM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Brake light problem

Assuming it's the 67 in your sig, the tail lights ground thru the housing and mounting studs. There is NO separate ground wire, at least on a 67 or 68. These problems can often be resolved by using star washers under a couple of the nuts that secure the tial light assy's.

Look at the lights VERY closely when testing.

These are 2 filament bulbs, with a common connection point on the ground side of both filaments. What you will often see is, if the parking lights are not on and you press the brake, BOTH filaments will glow. If the parking lights are on, both filaments will glow (dimly) until you press the brake, then both will go out.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
BRAKE PROBLEM!! Please Help!! mark67ss Brakes, Suspension & Steering 10 Jun 16th, 06 08:06 PM
Trun signal brake light problem 496hall Electrical & Wiring 0 Apr 28th, 05 09:24 AM
Plymouth Breeze brake problem SSupermanZ Brakes, Suspension & Steering 3 Aug 14th, 04 03:47 PM
Brake Warning Light Problem Rons68 Brakes, Suspension & Steering 2 Jun 17th, 02 04:15 AM
Brake Light slvrchvy Electrical & Wiring 1 Feb 25th, 01 06:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome