Turn signals quit - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Jul 2nd, 06, 06:16 PM Thread Starter
Brad
 
Join Date: Jun 2006
Location: Bedford, PA
Posts: 17
Turn signals quit

My signals on my 68 RS quit working yesterday on my way home. The four ways and all other lights work, just not the turn signals. Any suggestions on where I should look??
Highway308 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Jul 2nd, 06, 09:14 PM
Senior Tech
Brad
 
Join Date: Jun 2004
Location: Kauai HI
Posts: 644
Re: Turn signals quit

flasher under the dash.

Most recent 01/01/10


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
spideynut is offline  
post #3 of 5 (permalink) Old Jul 3rd, 06, 01:41 PM
Senior Tech
 
Join Date: Aug 2004
Location: PA
Posts: 819
Re: Turn signals quit

Might want to check the fuse also. The brake lights and 4-ways are on one fuse and turn signals and reverse lights on another.

69 RS 355 Tremec 5-Speed 4.11's
12run is offline  
 
post #4 of 5 (permalink) Old Jul 3rd, 06, 07:05 PM Thread Starter
Brad
 
Join Date: Jun 2006
Location: Bedford, PA
Posts: 17
Re: Turn signals quit

I didn't realize that there were two flasher units. I was the one I didn't know about up under the dash. Thanks.
Highway308 is offline  
post #5 of 5 (permalink) Old Jul 12th, 06, 05:38 PM
 
Join Date: May 2005
Location: Vancouver ,Canada
Posts: 26
Cool Re: Turn signals quit

My brake lights have stopped working on my 68 R.S. after a complete rebuild.I had a person following me run up at a red light to let me know I have no brake lights. I have checked all connections and bulbs and for the life of me I can't find why I keep losing my ground at the brake switch. It will work one minute and the next it just stops. Any suggestions. Thanks in advance..
teltec68 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
turn signals vegascamaro Electrical & Wiring 3 May 6th, 06 09:42 PM
68 Turn Signals rodutah Electrical & Wiring 7 Mar 12th, 06 05:19 PM
Littering and Turn Signals TJS69 Bench Racing 12 Sep 7th, 05 04:44 PM
turn signals not working kool Electrical & Wiring 1 Apr 18th, 05 04:51 PM
BRAKE lights OUT when USING THE TURN SIGNALS KED67 Electrical & Wiring 5 Jun 26th, 01 03:40 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome