Covans Sending Unit w/ Autometer Speedo Question - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jul 8th, 06, 06:14 PM Thread Starter
Senior Tech
Russ
 
Join Date: Nov 2005
Location: Cedar Rapids, IA
Posts: 540
Question Covans Sending Unit w/ Autometer Speedo Question

I have the Covan's Classic instrument panel with the Autometer Gauges. Currently having some difficulty with the calibration/operation of the Autometer Speedometer.

I purchased the two wire speed sensor directly from Covan's. It has 2 wires coming from it, 1 black and 1 white. These 2 connect to the 2 wires leading to the dash harness. Those 2 are purple and yellow (twisted pair, purple is signal and yellow is ground).

My question is which wire from the sensor is "signal" and which one is "ground"?? I assumed black was ground, but my speedometer isn't working. It'd be easy to switch them around down on the transmission, but I thought I'd check here first....

Any one else with the same setup?,, could you let me know which wire is which off the sensor on the tranny???

thanks.

Blown 69 RS Camaro

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


383 Small Block
Dyno: 578 Horse - 595 LB/Torque
Blown69RS is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jul 8th, 06, 07:39 PM
Senior Tech
Mike
 
Join Date: Sep 2002
Location: Raleigh, NC
Posts: 116
Re: Covans Sending Unit w/ Autometer Speedo Question

I can't say I know for sure, as my sender from Autometer via Covans had 3 wires on it. The black was ground, and the white was the signal. I had a red on e that went to the ign side for power.
greenham is offline  
post #3 of 4 (permalink) Old Jul 8th, 06, 09:47 PM
Senior Tech
Don
 
ZZ_430's Avatar
 
Join Date: May 2001
Location: Houston, Texas
Posts: 4,491
Re: Covans Sending Unit w/ Autometer Speedo Question

That's right. I thought to 2-wire was Ford only.

Don ~ TC Member #15 ~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Don't mess with Texas!
ZZ_430 is offline  
 
post #4 of 4 (permalink) Old Jul 20th, 06, 07:48 AM
 
Join Date: Jul 2006
Posts: 35
Re: Covans Sending Unit w/ Autometer Speedo Question

86 Z28 350TPI. I was sent a 2 wire sending unit with mine. After all was installed the car would shutdown around 35 miles per hour. What we found was that the unit was telling the ECM I was going 130 and the ECM was shutting off the fuel pump. Replaced with the 3 wire and now works great. I was told it has something to do with square wave signals vs something else which I still don't understand. Replaced chip and changed speedo gear in tranny to a gear with more teeth and now I know from experience my car will run 150 without the ECM shutting it down.
tawodi is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gas Tank, Gauge, Sending Unit WTF? BPOS Troubleshooting 8 Jul 12th, 06 03:44 PM
temp sending unit A69RS Tech 2000 9 May 9th, 06 10:15 PM
dual fuel line sending unit click Bench Racing 8 Aug 17th, 05 04:45 PM
fuel tank sending unit ohm reading. jrenschler Electrical & Wiring 2 Jul 13th, 02 02:13 AM
Water Temp Sending unit for Autometer Gauge Go69 Electrical & Wiring 7 Apr 25th, 02 07:33 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome