1987 5.0L TPI Z28 Engine problem - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Jul 14th, 06, 12:37 AM Thread Starter
 
Join Date: Jul 2005
Posts: 27
Angry 1987 5.0L TPI Z28 Engine problem

I posted in here because I beleive it to be an electrical problem. Here are my current specs:
1987 Camaro 5.0L TPI engine rebuilt and placed in a 1991 Camaro
Junkyard engine, distributor was NOT rebuilt
Electronic advance on distributor
New spark plug wires, MSD Coil, spark plugs, and ECM.
Old wiring harness with some custom wiring

The symptoms are:
-Engine used to be able to start, but never could be timed correctly, it would sputter, and jump, and backfire, no matter where I adjusted the distributor to
-Sometimes when engine was started it idled at 2000 RPMS! happened once every 20 times I think
-average idle was 250-500RPMs
-During timing it sputtered, slowly got worse, and stalled out, tried restarting the engine and it would not spark

Could I have overloaded the ignition module with the MSD blaster coil? The coil has a 42,000 volt rating. Could the old distributor need a few new parts, like rotor and cap? maybe a rebuild with MSD or Accel parts? Could it be a mechanical problem within the engine?

EDIT: Here is a link to a video I made when I was first running the engine. It was running open headers because the exhaust is not 100% finished. This should help you guys know how the engine was running. in this it was before it was timed enough to idle, it could not idle so I had to rev it once in a while

http://musclecartuners.net/videos/imbackinblack.wmv

Last edited by Racing_Master; Jul 14th, 06 at 12:50 AM.
Racing_Master is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Learning from revamping blower engine Tokyo Torquer Performance 11 Jan 24th, 07 12:44 PM
New Stroker Engine...But...A Problem (Long) bigdawginva Performance 57 Mar 11th, 05 02:33 PM
Sleuthing a new engine problem Tokyo Torquer Performance 16 Jan 3rd, 05 09:01 AM
EBAY or Build Balboni Performance 16 Jun 3rd, 03 10:16 AM
fuel problem HELP jokerdwarf Tech 2000 3 Dec 7th, 99 06:41 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome