Covan dash cluster check engine light problem. - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Aug 2nd, 06, 11:57 AM Thread Starter
 
Join Date: Jul 2006
Posts: 35
Question Covan dash cluster check engine light problem.

I have the Covan Autometer carbon fiber gauge setup in my 86 Camaro. The problem I have is that the LED check engine light stays on very dim. When there is a problem like a false EGR readout it glows brightly. The wiring has been checked several times to make sure the schematic was followed correctly. I called Autometer and learned their wiring is not of their manufacture but comes from a different source. The Autometer teck was helpful to confirm the right color wire was connected to the right color wire etc and my wiring is correct by the instructions provided etc. I was told that the light comes on when the circuit is grounded by the computer. We checked for a false ground/short and could not find anything.
Has anyone with the Corvan setup had or have this problem? Does anyone have a suggestion to correct this problem?
tawodi is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lobe Separation Angle questions 69ProTouring Performance 19 Oct 10th, 05 05:41 PM
85 iroc check engine light 85iroc Troubleshooting 8 Sep 10th, 02 04:29 PM
Service engine light soon light flashes jrich10 Troubleshooting 8 Dec 25th, 01 06:51 AM
Check Engine light will not go OFF lawiv Troubleshooting 4 Nov 10th, 01 08:41 PM
fuel problem HELP jokerdwarf Tech 2000 3 Dec 7th, 99 06:41 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome