Turn signal fuses keep blowing???? - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Aug 8th, 06, 06:35 PM Thread Starter
Senior Tech
 
Join Date: Apr 2001
Location: Newark, Ohio
Posts: 706
Turn signal fuses keep blowing????

So after two months of not driving my car due to a camshaft change a death in the family, I finally got the car running last night. i took it for a drive and as soon as I used the turn signals once I blew the fuse.

I never had this problem before and the only wiring I disconnected was the battery and the MSD box. I blew a 20 AMP fuse and then i put in a 15 AMP because thats all I had and blew that one too.

What should I be looking for to fix this problem??

Thanks, Erik

67 Camaro Pro Street, 540 Bill Mitchell Merlin big block, Merlin Aluminum heads, Holley 870, hydraulic camshaft, 2" Hooker Super Comp headers, Mallory and Crane ignition system, TH400, 2600 stahl, Ford 9" w/ 4:10 gears and posi.
Erik Beckett is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Aug 9th, 06, 07:32 PM Thread Starter
Senior Tech
 
Join Date: Apr 2001
Location: Newark, Ohio
Posts: 706
Re: Turn signal fuses keep blowing????

Anybody got any suggestions? I replaced the fuse and put a new flasher in but it happened again.

Erik

67 Camaro Pro Street, 540 Bill Mitchell Merlin big block, Merlin Aluminum heads, Holley 870, hydraulic camshaft, 2" Hooker Super Comp headers, Mallory and Crane ignition system, TH400, 2600 stahl, Ford 9" w/ 4:10 gears and posi.
Erik Beckett is offline  
post #3 of 6 (permalink) Old Aug 9th, 06, 08:34 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Turn signal fuses keep blowing????

if I have to take a wild guess, I'd say pull the turn signal switch and the wiring out of the column, look for some broken insulation that was grounding out a wire.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
 
post #4 of 6 (permalink) Old Aug 24th, 06, 08:03 PM
 
Join Date: Jun 2005
Posts: 41
Re: Turn signal fuses keep blowing????

ttt

Just developed the same problem.

No apparent reason for the failure just started blowing a fuse.

If I replace the fuse the hazards work fine which suggests its not a problem with the bulbs or holders.

Last edited by DeeGee; Aug 24th, 06 at 08:33 PM.
DeeGee is offline  
post #5 of 6 (permalink) Old Aug 25th, 06, 07:35 AM
Senior Tech
Sean
 
Join Date: Feb 2002
Location: N.W. Washington
Posts: 7,991
Re: Turn signal fuses keep blowing????

Look for corrosion or rust at the fuse terminal, my car did the same thing when I bought it, the resistance created from the rust would build heat and fry the fuse, once I cleaned the terminals of rust and crud, it's all good. 9 times out of 10 with our old cars it will be a poor connection or a bad ground.
It could be a bad switch too, but I'd check all the easy stuff first.

Sean

1968 rs with an old school 354" SB2.2 pump gas motor.

Repetition does not transform a lie into a truth.

Franklin D. Roosevelt
68rs406 is offline  
post #6 of 6 (permalink) Old Aug 26th, 06, 11:35 AM Thread Starter
Senior Tech
 
Join Date: Apr 2001
Location: Newark, Ohio
Posts: 706
Re: Turn signal fuses keep blowing????

Well, I found the problem as to what was causing the fuse to blow. Stupid me!!! The car was originally a 4 speed car and the back up lights wiring go into the firewall and come out in the engine bay with a two prong connection on it. Well, after doing all this new engine work, my ground strap was actaully laying across these two terminals and blowing the fuses. It took two days and 6 hours to find this simple problem but it is fixed.

Thanks, Erik

67 Camaro Pro Street, 540 Bill Mitchell Merlin big block, Merlin Aluminum heads, Holley 870, hydraulic camshaft, 2" Hooker Super Comp headers, Mallory and Crane ignition system, TH400, 2600 stahl, Ford 9" w/ 4:10 gears and posi.
Erik Beckett is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
69 Camaro Turn Signal Cancelling Cam billscamaros Brakes, Suspension & Steering 2 Mar 20th, 06 06:00 PM
Turn Signal Fuse Blowing DeeGee Electrical & Wiring 9 Dec 30th, 05 11:44 AM
68 Turn Signal??? bdcole_51 Electrical & Wiring 1 Sep 4th, 05 05:41 PM
Turn Signal Problem rookie68camaro Electrical & Wiring 2 Mar 20th, 05 03:28 AM
Tail Light Short & Turn Signal Switch KED67 Electrical & Wiring 3 Jun 25th, 01 08:40 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome