Problem with turn signals - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Aug 8th, 06, 08:44 PM Thread Starter
Bret Ervin
 
Join Date: May 2006
Location: Sacramento, California
Posts: 2
Problem with turn signals

Slight problem with turn signals, I think it might be a flasher problem but wanted to here fromt the experts. First off I have no turn signals at all either side and now when I hit the brake pedal the front parking lights come on with the rear brake lights. Any ideas where to start looking? Any help would be greatly appreciated!!!!!!!!!!!!!!
dirtshark is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Aug 8th, 06, 09:25 PM
Senior Tech
Steps
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,319
Re: Problem with turn signals

Check your earths

My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline  
post #3 of 5 (permalink) Old Aug 9th, 06, 09:30 PM
Senior Tech
Scott
 
Join Date: Apr 2005
Location: CA
Posts: 239
Re: Problem with turn signals

Do your hazard flashers work as they should?

The usual reason for the front signals coming on with the brake lights is the hazard switch being turned on. If your hazard flasher is bad and the hazard switch is turned on, this could be the whole problem. Be sure the hazards are turned off and see what happens.
red67camaro is offline  
 
post #4 of 5 (permalink) Old Aug 9th, 06, 09:34 PM
Team Member
Steve
 
Join Date: Nov 2005
Location: East SF Bay Area
Posts: 1,787
Garage
Re: Problem with turn signals

Quote:
Originally Posted by Steptoe
Check your earths
aka your grounds.
check all of your grounds.

Steve
1968 that started life and a 6 banger with a PG. Now it's a 350 with a TKO600, Moser 12 bolt, Speedtech LCA/UCA, ATS Tall Spindles, Hotchkis Springs, Forgeline ZX3P, C5 (Kore3) brakes with other cool stuff from Ron Davis, Vintage Air and soon to be Terminator EFI.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
eville is online now  
post #5 of 5 (permalink) Old Aug 11th, 06, 07:24 AM Thread Starter
Bret Ervin
 
Join Date: May 2006
Location: Sacramento, California
Posts: 2
Smile Re: Problem with turn signals

Thank you all for your responses. Red67 you were right on, problem with the flasher button on column. I was able to pull out clean up contact areas reinstall and WA LA I have turn signals again.

Thanks much..........
dirtshark is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Littering and Turn Signals TJS69 Bench Racing 12 Sep 7th, 05 04:44 PM
turn signals not working kool Electrical & Wiring 1 Apr 18th, 05 04:51 PM
67 Turn signal problem broom34 Electrical & Wiring 0 Apr 1st, 05 07:34 AM
BRAKE lights OUT when USING THE TURN SIGNALS KED67 Electrical & Wiring 5 Jun 26th, 01 03:40 PM
Turn signals..please help!! budman93 Troubleshooting 1 May 7th, 01 12:05 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome