need help - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Aug 30th, 06, 09:36 PM Thread Starter
Tech Team
 
Join Date: Sep 2004
Location: erie,pa
Posts: 33
need help

i have a 67 camaro.the problem i am having starting.i have a msd 6al .i have a switch for to on an off.when i have the switch off the starter turns very good but when i have the switch on the starter turns very poor like a dead battery.any advise would be helpful an maybe someone having same problem.thanx for your help kenz67

i have a 67 camaro on the tag it has a 2mg 3k on it what does that stand for thankz for your help .ken
kenz67 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Aug 30th, 06, 09:39 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: need help

you need to check your ignition timing (initial) you are too far advanced.

If you don't know how, or don't have a timing light, start by loosening the distributor hold down bolt and turning it clockwise a LITTLE bit, tighten the bolt and try it, if it's still not right, go a little more.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #3 of 5 (permalink) Old Sep 2nd, 06, 05:43 PM Thread Starter
Tech Team
 
Join Date: Sep 2004
Location: erie,pa
Posts: 33
Re: need help

jim i was wondering how it can be igition timing when the starter does not turn.when have the box off it turns the starter tunrs good but when the box is off it turns poor

i have a 67 camaro on the tag it has a 2mg 3k on it what does that stand for thankz for your help .ken
kenz67 is offline  
 
post #4 of 5 (permalink) Old Sep 2nd, 06, 06:02 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: need help

The ignition is firing when the piston is still moving up. The expanding gasses in the cylinder are whats loading the starter.

Adjust the timing.

One thing the racers do sometimes is have two switches like you have, hit the starter and get her spinning, then flip on the ignition and she starts!





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #5 of 5 (permalink) Old Sep 21st, 06, 08:52 PM Thread Starter
Tech Team
 
Join Date: Sep 2004
Location: erie,pa
Posts: 33
Re: need help

jim to let you know it was the msd box is faulty.thanks for the help though

i have a 67 camaro on the tag it has a 2mg 3k on it what does that stand for thankz for your help .ken
kenz67 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome