Outer Left Tail Light Won't Light Up - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Oct 5th, 06, 10:10 PM Thread Starter
 
Join Date: Apr 2004
Posts: 152
Outer Left Tail Light Won't Light Up

The outermost left tail light in my '67 RS/SS won't light up. I put in a new bulb and still doesn't light up. When I turn on the left turn signal, the green arrow on the dash just stays lit up and the front left turn signal light also just stays lit, likely because this outer left tail light doesn't light up. The other three tail lights (left inner, right inner and right outer) work fine. Looks like the wiring to this light is coming from the turn signal switch and the light switch/knob on the dash. Any ideas on what the problem could be? I don't think it's a bad ground since the left inner tail light uses the metal housing for a ground and it's working fine.
SFCamaro is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Oct 6th, 06, 07:02 AM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Outer Left Tail Light Won't Light Up

Sounds like you have a ground issue on the left side. Kinda odd cause it would usually take out both bulbs on that side too tho...

You might start by cleaning up the metal back of the tail light housing with some steel wool around where that socket plugs in, and clean/check the lil tabs on the socket that makes the connection. It never hurts to put a star washer under one of the nuts that secures the housing in the tail pan. Check the ground connection on the front parking light on that side, too. This is a ground wire with a ring terminal, in the lighting harness, that connects to the headlight support bracket.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #3 of 3 (permalink) Old Oct 6th, 06, 01:05 PM Thread Starter
 
Join Date: Apr 2004
Posts: 152
Re: Outer Left Tail Light Won't Light Up

Thanks for the advice. I found the problem. The ground was fine. But the spring contacts in the socket were not fitting tight enough against the bulb contacts. I pulled up the spring contacts with a screwdriver to create a more tension against the bulb and now it works.
SFCamaro is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signal & tail light not working SGcamaro Electrical & Wiring 0 Aug 21st, 05 05:34 PM
left RS light always opens up? MStennes Body Shop 1 Sep 8th, 03 09:21 AM
69 Tail Light Chrome Unreal Body Shop 3 Nov 17th, 01 11:53 AM
Tail Lights/Blinker Light stays solid MTidwell Electrical & Wiring 1 Oct 19th, 01 02:09 AM
Really Need Help with Tail Light Problem! daverichard Electrical & Wiring 8 Jun 16th, 01 07:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome