Tach Problems - Recalibrate? - Team Camaro Tech
Camaros.net Site Help Discussion Website questions, comments, suggestions and tech help.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Jun 3rd, 04, 06:57 AM Thread Starter
 
Join Date: Jun 2004
Posts: 2
Post

I have a '70 Z28 with the factory tach that reads about 30% low (compared to a known good hand held tach). It has an MSD HEI distributor and the fusible-link resistor wire has been removed. Does any one know of a reliable place that can recalibrate it? I'm in the south-east part of Wisconsin and would like to find some body in the area if possible. If not I guess I'll have to ship it.
Thanks.
Fat Chance is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome