94 Z28 Lt1 Backfiring,missing after a few miles - Team Camaro Tech
Test Drive! New to this area?
Get comfortable here by posting and editing your own messages.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Oct 25th, 07, 05:39 AM Thread Starter
 
Join Date: Oct 2007
Posts: 1
Angry 94 Z28 Lt1 Backfiring,missing after a few miles

New to site - HELP - I have a 94 Z28 LT1 (84,000+ miles) It starts right up and idles smooth as can be (for hours if I let it), but as soon as I drive a mile (or 2 or 3 or 4) it starts missing like hell, backfiring or wants to die. If I keep the RPMs up I just hope it makes it back home. Also, the amount of gas it goes thru is just amazing, but there is no gas odor or leakage.
Back home (by luck) I can turn it off and then start it up and I'll be damn, it idles as smooth as can be again. HELP
geo_sis is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Oct 25th, 07, 06:13 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 32,005
Garage
Re: 94 Z28 Lt1 Backfiring,missing after a few miles

Optispark going bad?
Has it ever been changed?
Gradual problem or develop overnight?
Broken fuel pressure regulator diaphram? Pull off vacuum hose to see fuel, should be dry.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome