Dash and running lights not working - Team Camaro Tech
Test Drive! New to this area?
Get comfortable here by posting and editing your own messages.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old May 17th, 10, 10:52 AM Thread Starter
Jerry
 
Join Date: May 2010
Location: Burson, Ca
Posts: 5
Dash and running lights not working

I have a 69 standard coupe with a V8350 automatic. It is in running condition till I start resto. Recently the dash lights and running lights quit working. I replaced the light switch, nothing. I remove the connector to the switch and using a jumper wire I can get all the lights to work. All fuses are good. What am I missing to get these lights working?
69newbie is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old May 17th, 10, 10:57 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,587
Garage
Re: Dash and running lights not working

Another headlamp switch providing all external of the switch is the same.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - maybe this year, 2019 ...
Everett#2390 is offline  
post #3 of 4 (permalink) Old May 17th, 10, 11:20 AM Thread Starter
Jerry
 
Join Date: May 2010
Location: Burson, Ca
Posts: 5
Re: Dash and running lights not working

Not sure what you mean?
69newbie is offline  
 
post #4 of 4 (permalink) Old May 17th, 10, 11:31 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,587
Garage
Re: Dash and running lights not working

Another member here, I believe had the same problem and it turned out to be the repo headlamp switch.

If nothing else other than the switch has been changed since last time the lights worked, then its the switch. From your first post, you jumpered across the connector to get the lights of choice to work, and they did. If the harness connector to the switch has not been changed from as manufactured, then its the replacement switch.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - maybe this year, 2019 ...
Everett#2390 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome