what is the most loaded trimtag you have seen? - Team Camaro Tech
Tech 2001 General Tech questions from 2001
Replies ONLY, no new topics.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Dec 13th, 01, 11:58 AM Thread Starter
Senior Tech
Tim
 
Join Date: Jul 2000
Location: Midland
Posts: 172
Post

One reason '67's are my favorite year is because they pretty much document themselves. What is the most loaded trim tag you have ever seen? I don't want to list my contender yet - how 'bout yours??
Flatt67 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Dec 13th, 01, 04:25 PM
Tech Team
 
Join Date: Jun 2001
Location: Ridley Park, PA, USA
Posts: 57
Post

Don't know if mine is 'loaded' but I know it is authentic. RS/SS/Convertible with PG/PS/Rochester Quadrajet, Power Top,No Power Brakes. Can supply copy of ID and Protecto-plate if you need info. Have owned since 71, just got it back on the road and loving it.
Cheers,
Jim H.
jimbarbh is offline  
post #3 of 5 (permalink) Old Dec 14th, 01, 12:30 AM
Moderator
Jeff
 
Join Date: Dec 2000
Location: Manhattan Kansas
Posts: 3,176
Thumbs up

Jim sounds like one nice car. If you have not yet can you post all the car info in the trim tag section so it can be recorded. no doubt would think Kurt S would like to get a copy of your pop also.
Mahalo from Hawaii
Jeff 67/68 & 69 RS's
65 442
HawaiianCamaro is offline  
 
post #4 of 5 (permalink) Old Dec 15th, 01, 05:36 AM
Gold Lifetime Member
Jack
 
Join Date: Sep 2000
Location: Gilbert, Az. USA
Posts: 1,677
Post

12C N359
ST 67 12637 LOS 11809
797-Z M6
E 2EMGSR 3SL
5Y

I am just finishing this one and it now matches the tag except for the A/C.
Coded for A/C but never got it ???

And more interesting, this week I saw a 67 rs, 6 cyl 3 speed on column, rear antenna and interior decor with standard black buckets. Matched the trim tag 100%. An Arizona survivor car. It even had the 5 spoke "mag" hubcaps.
jackr is offline  
post #5 of 5 (permalink) Old Dec 15th, 01, 06:13 AM Thread Starter
Senior Tech
Tim
 
Join Date: Jul 2000
Location: Midland
Posts: 172
Post

Wow, I've never seen one coded for- but not getting a/c!!
Flatt67 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome