Sway Bar Clearance Question - Team Camaro Tech
LSx Swap LSx Engines in Non-LSx Vehicles

 2Likes
  • 1 Post By 67Rally
  • 1 Post By 67Rally
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old Mar 19th, 17, 01:50 PM Thread Starter
Apprentice
Derrick
 
Join Date: Nov 2008
Location: Northern Virginia
Posts: 14
Sway Bar Clearance Question

I am installing a 6.0 into my 1969 Camaro and I am running into clearance issues with the sway bar. I am using Dirty Dingo Double D mounting plates and when I position them to clear the steering linkage, I run into issues with the sway bar. I have a stock subframe. I could not find it anywhere but is the a common issue? Is the fix just to go with a different sway bar?



weasle is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Mar 19th, 17, 02:51 PM
DT
Gold Lifetime Member
Donny
 
DT's Avatar
 
Join Date: Jun 2005
Location: Rockland Cty/Melb bch Fla
Posts: 5,217
Garage
Re: Sway Bar Clearance Question

What vehicle did that engine come out of ?? Can you change the balancer to a smaller one ??

1969 X66 396 LeMans Blue, M20, 373 (Sold)
1969 Convertible LS3 TKO 600, 373
DT is offline  
post #3 of 8 (permalink) Old Mar 19th, 17, 03:47 PM Thread Starter
Apprentice
Derrick
 
Join Date: Nov 2008
Location: Northern Virginia
Posts: 14
Re: Sway Bar Clearance Question

Quote:
Originally Posted by DT View Post
What vehicle did that engine come out of ?? Can you change the balancer to a smaller one ??
It came out of a 2001 chevy 2500 HD truck.
weasle is offline  
 
post #4 of 8 (permalink) Old Mar 19th, 17, 05:15 PM
DT
Gold Lifetime Member
Donny
 
DT's Avatar
 
Join Date: Jun 2005
Location: Rockland Cty/Melb bch Fla
Posts: 5,217
Garage
Re: Sway Bar Clearance Question

Quote:
Originally Posted by weasle View Post
It came out of a 2001 chevy 2500 HD truck.
Isn't the corvette balancer smaller??

1969 X66 396 LeMans Blue, M20, 373 (Sold)
1969 Convertible LS3 TKO 600, 373
DT is offline  
post #5 of 8 (permalink) Old Mar 19th, 17, 05:30 PM
Gold Lifetime Member
Brent
 
67Rally's Avatar
 
Join Date: Feb 2010
Location: Boston, MA
Posts: 4,805
Garage
Re: Sway Bar Clearance Question

What frame mounts do you have? Could you go with a taller mount?
DT likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
67Rally is offline  
post #6 of 8 (permalink) Old Mar 20th, 17, 01:49 PM Thread Starter
Apprentice
Derrick
 
Join Date: Nov 2008
Location: Northern Virginia
Posts: 14
Re: Sway Bar Clearance Question

Thanks guys, I will look into these options.
weasle is offline  
post #7 of 8 (permalink) Old Mar 20th, 17, 02:17 PM
Gold Lifetime Member
Brent
 
67Rally's Avatar
 
Join Date: Feb 2010
Location: Boston, MA
Posts: 4,805
Garage
Re: Sway Bar Clearance Question

I have the "tall & narrow" '69 Camaro mounts for a 302/350. Part #'s 3945507 and 3945508.

FWIW, they work with my LQ9, Dirty Dingo Sliders, Energy Suspension (3-1117G) poly motor mounts, and Hotchkis front sway bar.
DT likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
67Rally is offline  
post #8 of 8 (permalink) Old Mar 20th, 17, 05:13 PM
Moderator
____
 
DOUG G's Avatar
 
Join Date: Mar 1999
Location: Maryland, USA
Posts: 19,625
Garage
Send a message via MSN to DOUG G
Re: Sway Bar Clearance Question

Had this issue when I went to a 400 (8" balancer). My "quick fix" was to add spacers under the sway bar frame mounts. So "if" this was going to be an issue....It was already addressed

I took the bracket off, made a rectangle 1/2" thick spacer, drilled the 2 holes in them so they wouldn't fall out , and added some longer bolts...been good for a long time now.

68 Camaro~LSx ~all motor
1.54 60'--6.95 @ 98.45 660'--10.96 @ 121.53
DOUG G is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome