summit fuel pressure guage - Team Camaro Tech
Tech 2002 General Tech questions from 2002
Replies ONLY, no new topics.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old May 29th, 02, 01:31 PM Thread Starter
Senior Tech
David
 
Join Date: May 1999
Location: Jefferson City, MO.
Posts: 621
i installed a liquid filled summit fuel pressure gauge in-line by the carburetor, the small 1 1/2" guage. my problem is fuel pressure seems to drop to 2 or even one sometimes at idle, other times 6-7, although the car runs fine on the road. i was thinking the gauge is the problem, i have tthe edelbrock street pump on the car. anyone have any experience with the summit guage? David

------------------
67 RS marina blue
SUPER T10 4 SPD
377, demon carb
91 formula 350 firebird (wifes car)
01 siverado 2500HD
67FREAK is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old May 29th, 02, 01:41 PM
Gold Lifetime Member
Rick
 
Join Date: Feb 2000
Location: Accord, NY
Posts: 4,815
As my fuel filter started plugging I would see the same thing. I'm not saying the gauge is not the problem but my car would seem to run OK, too. It's a cheap and not bad idea anyhow to change your filter and see if the pressure improves. I also removed the sock in the tank as it was catching stuff also. I'd rather rely on the inline filter. I wound up getting an Autometer electric pressure gauge and mounted it in the car.

------------------
Rick Dorion
69 RS Conv,355,M20,4.10's and I don't worry about stone chips ( yet ).
RickD is offline  
post #3 of 4 (permalink) Old May 29th, 02, 02:01 PM
Senior Tech
Don
 
ZZ_430's Avatar
 
Join Date: May 2001
Location: Houston, Texas
Posts: 4,491
67FREAK, yes, I know exactly what you mean.

I tried 3 Summit liquid filled gauges...I'm not bashing, but IMHO they are junk. Off-shore imported....

I got a Russell gauge now and it works great.

Also Holley makes a decent one.


------------------
Don~ ZZ430DropTop
~~~~and~~~~
70 RS/Z28
67 RS/SS Convertible, 70 RS/Z28
ZZ_430 is offline  
 
post #4 of 4 (permalink) Old May 29th, 02, 02:52 PM
Senior Tech
 
Join Date: Apr 2001
Location: Out here
Posts: 111
Yepper just bought one myself. installed it and had 3 lbs/in^2 @ idle. Took out the little threaded plug and got 7.5 or so but i would watch the pressure drop as everything got warm. Piece of junk.
psalm69 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome