89 iroc z cooling issue - Team Camaro Tech
Heating & Cooling Heating, cooling and air conditioning

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old Apr 26th, 07, 04:20 PM Thread Starter
 
Join Date: Apr 2007
Location: Cortland, Oh.
Posts: 4
89 iroc z cooling issue

I have an 89 Iroc 5.7 tpi. The cooloing fans are not coming on. It doesn't run when the a/c is on or when the temp rises above 240. I have researched the archives and am wondering how I decide if it's the relay, the switch, or the ecm? I know where the relay is, where is the cooling switch and the ecm.

I disconnected the relay and ran a jumper across the the harness for the fan and the fan came on (ignition key was on and temp was about 240). Is this a sure fire indicator that the relay is bad?

Thanks for any help,
Frank
FrankF199 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old Apr 26th, 07, 05:29 PM
 
Join Date: Jan 2007
Posts: 601
Re: 89 iroc z cooling issue

there is always power going to the relays. i think you got 2 relays 1 for coolant temp and another for a/c. a ground completes the circuit for the fan to come on. if 1 fan coolant turns it slowly ac makes it faster. if 2 fans 1 comes on with coolant temp other comes on with a/c.
jaguareats is offline  
post #3 of 10 (permalink) Old Apr 26th, 07, 06:14 PM Thread Starter
 
Join Date: Apr 2007
Location: Cortland, Oh.
Posts: 4
Re: 89 iroc z cooling issue

OK thanks, that makes sense cuz when I jumped the relay, the passenger side fan came on only. So now it sounds like the relay must be okay. Where can I find the cooling fan switch and how can I test it?

Thanks,
Frank
FrankF199 is offline  
 
post #4 of 10 (permalink) Old Apr 27th, 07, 03:23 PM
Senior Tech
 
Join Date: May 2001
Location: Ashby,MN, USA
Posts: 8,305
Re: 89 iroc z cooling issue

i think it goes into the intake manifold somewhere.
once you do find it, you can pull the wire off and ground it to see if that makes the fan turn on. if the fan turns on, then the switch is bad. you can get a colder switch at NAPA if you want the fans to come on earlier- but they will have to break out the big book with pictures of all the temp switches and their temp ratings to find one that will work for you.

you don't plan sincerity.
you have to make it up on the spot.

wanna hear about 20 years ago when i was too smart to know any better?
novaderrik is offline  
post #5 of 10 (permalink) Old Apr 27th, 07, 03:27 PM
 
Join Date: Jan 2007
Posts: 601
Re: 89 iroc z cooling issue

the sensor is right by the thermostat housing 1 is for guage and another for fan to come on. if you disconnect it the fan should come on. if it does than relay is ok. if it dont the ecm is no good. the ecm grounds the relay and than fan comes on.
jaguareats is offline  
post #6 of 10 (permalink) Old Apr 28th, 07, 04:43 PM Thread Starter
 
Join Date: Apr 2007
Location: Cortland, Oh.
Posts: 4
Re: 89 iroc z cooling issue

OK, guys thanks, I pulled the connection from the sensor. Started the engine and let the coolant temerature come up to about 130 on the guage. I then shut the engine off and turned the ignition key on. I then grounded the sensor and the fans DID NOT come on. (BTW, there is only one relay for both fans)

Am I to assume this means the ECM module is bad?

Thank you for all your help, the car is my sons and I'm trying to save him some money by fixing this for him instead of takeing it to the dealership.

Thanks again,
Frank
FrankF199 is offline  
post #7 of 10 (permalink) Old Apr 28th, 07, 06:12 PM
 
Join Date: Jan 2007
Posts: 1,163
Re: 89 iroc z cooling issue

i wouldnt call the ecm bad without testing the harness, and running a data stream from the ecm through a scanner...i`d call the relay bad before the ecm...how did you test the relay???
kustomwerker is offline  
post #8 of 10 (permalink) Old Apr 29th, 07, 06:32 PM Thread Starter
 
Join Date: Apr 2007
Location: Cortland, Oh.
Posts: 4
Re: 89 iroc z cooling issue

i pulled the connector and ran a jumper wire across the connector, when i did this the fan came on. I assumed the relay was bad but everyone else is saying it's the ecm.

Thanks,
Frank
FrankF199 is offline  
post #9 of 10 (permalink) Old Apr 30th, 07, 06:10 PM
Gold Lifetime Member
Mitch
 
Lost in the 60's's Avatar
 
Join Date: Oct 2006
Location: Stillwater, MN
Posts: 2,345
Re: 89 iroc z cooling issue

Those fans are notorious for problems. My 88 is wired to a switch on the dash because the harness plug at the fans had melted in the past. There is another site dealing mostly in 3rd and 4th gen F bodies that has a lot of info on troubleshooting and repairing the fans on them. It's www.thirdgen.org

...38 Chev coupe, street rod
...54 Chev 210 coupe
...62 Impala SS, driver/project
...67 Camaro, ss/rs LA built driver/project
...66 Chevelle SS, Atlanta built 138 driver/project
...69 C10, cab and clip may end up on the '89 rollback
...70 Chevelle SS, Canadian documented Z25 project
Lost in the 60's is offline  
post #10 of 10 (permalink) Old Apr 30th, 07, 07:23 PM
 
Join Date: Jan 2007
Posts: 1,163
Re: 89 iroc z cooling issue

start with the relay...it`s easy...if you absolutely cant get it working, order an electric fan thermostat kit from summit or jegs and be done with it...they`re about 40 bux, and they have a bulb that goes inbetween the cores of the rad...then YOU set the temp that they come on...your car wont run hot anymore...
kustomwerker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!! Can't figure out this cooling issue Luke805 Heating & Cooling 4 Mar 21st, 05 03:11 AM
'97 Cooling Issue SRP44 Heating & Cooling 2 Apr 10th, 04 04:10 PM
Cooling Issue? bretcopsey Engine 3 Jan 21st, 03 01:51 AM
Reasons to keep my Iroc? Timmys88Z Tech 2002 8 Jan 28th, 02 07:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome