Fan not functioning properly - Team Camaro Tech
Heating & Cooling Heating, cooling and air conditioning

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jul 6th, 07, 06:24 AM Thread Starter
 
Join Date: May 2007
Posts: 7
Fan not functioning properly

I have an 89 RS with the 305(V8). My radiator fan stoped turning on by itself. So i went and replaced every sensor on the block that delt with the fan and cooling system. While it wasnt working i was using a toggle switch and contoling the fan manually myself. So i know its not the fan itself. After replacing everything i wired it back to normal and it work fine by itself for a day and a half. Now its not working again. Does anyone have an idea.
HAULINanBALLIN is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jul 6th, 07, 06:57 AM
Tech Team
Rich
 
Join Date: Dec 2006
Location: OH
Posts: 30
Re: Fan not functioning properly

More than likely it is the relay..... try replacing it first.
Cyclone is offline  
post #3 of 4 (permalink) Old Jul 6th, 07, 07:02 AM Thread Starter
 
Join Date: May 2007
Posts: 7
Re: Fan not functioning properly

It has a brand new 1. That was replace when i replace the thermostat, the cooling fan switch on the bottom of the block, and the other cooling sensor on the top of the block. Ive got the old one and i know it still works so ill try that.
HAULINanBALLIN is offline  
 
post #4 of 4 (permalink) Old Jul 6th, 07, 01:18 PM
Senior Tech
Charlie
 
Join Date: May 2007
Location: Baltimore Maryland
Posts: 3,759
Re: Fan not functioning properly

Did the car ever actually over heat where the coolant boiled over? If so, then that automatically destroys the coolant temp sensor. That will have to be replaced, no if's about it, but only if the car boiled coolant.

Charlie Knudsen 67 Camaro RS/SS 350 TKO 600, 4.10's, AFR 195 Street Heads, Comp 270H, Rhoads Lifters, Crane Ignition, Pertronix Dizzy, Performer RPM Q-Jet, Heavily Modified Q-Jet, Hooker Comp Headers, MagnaFlow 2 1/2", 144 Decibles(Alpine CDA-7998 Head Unit, RF X7 and RF 750X Amps, MB Quart Mid's & High's, Kicker L7 12" Solo Barics)
67CamaroRS/SS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
clutch fan wobble KURT Heating & Cooling 5 Jul 23rd, 06 05:24 AM
Flex fan being trashed/why not weld a clutch fan? wheezer Heating & Cooling 4 Jul 15th, 06 05:06 AM
Another clutch fan question . . . Mark Rossiter Heating & Cooling 1 Jun 16th, 06 09:36 AM
68 Z28 fan blade dimensions bwhitfield Heating & Cooling 2 Apr 4th, 06 07:50 AM
Cooling Fan Question SKIPS69 Heating & Cooling 10 Sep 6th, 05 08:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome