Cooling systems 123 - Team Camaro Tech
Heating & Cooling Heating, cooling and air conditioning

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Aug 24th, 07, 05:51 AM Thread Starter
Senior Tech
Brian
 
Join Date: Nov 2000
Location: Ontario, Canada
Posts: 1,290
Cooling systems 123

I have a 68 Camaro with the 327 275 horse engine. I have had no problems with this car for 4 years. I recently changed the aftermarket rad cap (13 lbs)for a RC 27 cap I had. It is an AC rated for 15 libs. Twice now it burped fluid. I then purchased an RC 26 (AC 15 lb) and tried that. This one caused my top rad hose to leak at the rad and the top hose was hard as a rock. I was wondering what could be causing these things to happen. Is it just a coincidence and something else is wrong. My temp guage stays on 190 all the time. I put a little more fluid in and I am wondering if it is too full?
Before changing the 13 lb cap I never had a problem. I have since put that one back but I have yet to test it.
Any Ideas?

I have owned 3 69 Z/28s: Garnet Red 30,000 mi unrestored.
Glacier Blue, documented Canadian Z
Rallye Green purchased new in 1969
1968 Camaro Coupe L30 275 horse. ]
Stewie is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Aug 24th, 07, 06:38 AM
Senior Tech
 
Join Date: Dec 2001
Location: Fairfield, CA
Posts: 6,246
Re: Cooling systems 123

If your temperature gauge stays at 190 all the time it's broken. It should return to ambient after you let the engine cool.
The rest of the operation seems normal. I would tighten the top hose.
Do you have a puke tank?
Did you refill the radiator when you changed the caps?
onovakind67 is offline  
post #3 of 5 (permalink) Old Aug 24th, 07, 07:31 AM Thread Starter
Senior Tech
Brian
 
Join Date: Nov 2000
Location: Ontario, Canada
Posts: 1,290
Re: Cooling systems 123

Sorry I meant it stays on 190 after warmup. I don't have a puke tank and haven't needed one up to now. I did refill the rad and I think I overfilled it.
I will check the upper hose and see if that is tight enough.

I have owned 3 69 Z/28s: Garnet Red 30,000 mi unrestored.
Glacier Blue, documented Canadian Z
Rallye Green purchased new in 1969
1968 Camaro Coupe L30 275 horse. ]
Stewie is offline  
 
post #4 of 5 (permalink) Old Aug 24th, 07, 08:23 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 32,178
Garage
Re: Cooling systems 123

I'd put the aftermarket cap back on. If it ain't broke, don't fix it, or keep fixing it till it does break.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is online now  
post #5 of 5 (permalink) Old Aug 24th, 07, 10:05 AM Thread Starter
Senior Tech
Brian
 
Join Date: Nov 2000
Location: Ontario, Canada
Posts: 1,290
Re: Cooling systems 123

I have already put it back on. I was able to tighten the top hose clamp a couple of turns so I think it was loose.

I have owned 3 69 Z/28s: Garnet Red 30,000 mi unrestored.
Glacier Blue, documented Canadian Z
Rallye Green purchased new in 1969
1968 Camaro Coupe L30 275 horse. ]
Stewie is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome