what e-fans are you guys running?? - Team Camaro Tech
Heating & Cooling Heating, cooling and air conditioning

 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old Jul 27th, 10, 06:47 PM Thread Starter
Senior Tech
Brian
 
Join Date: Apr 2009
Location: tacoma, wa
Posts: 236
Send a message via AIM to joyride_
what e-fans are you guys running??

my dad finally wants to get rid of his flexfan for an e-fan setup like i have on my s10 xtreme...

and his stock radiator is so small...he has no cooling issues at all right now, but wants to free up some hp by doing any lil' thing here and there that he can...

i'm currently running a ford taurus fan on my truck with a built 4.3...and it does the job more than fine...and it would fit in his just fine...but it's mine, so he can't have it. lol...

wondering what ones you guys are using....especially people w/ their stock radiators, or aftermarket ones that are the same size i guess...i've been searching craigslist and ebay and i found a lincoln mark VIII, that says it has 4300 cfm...i have no idea how much that is, but seems to be more than the others i have found...lol

his shows 22x19x5...i rounded up on each of those...

i've searched as well but i would rather just like to get an idea of which ones would work and cool enough, especially for a drag race motor. he is estimating he has 540 hp motor, not to the ground.

thanks again, brian.

Brian
MY RIDE

01 S10 Xtreme 2/3 drop, BUILT 4.3L v6, 5spd
DADS RIDE
69 Camaro 500+ hp 355, t400, currie ford 9inch 4.56 gears, 100 shot
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
joyride_ is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old Jul 27th, 10, 08:30 PM
Senior Tech
Ted
 
Join Date: Dec 2005
Location: Cedar Rapids, IA
Posts: 1,810
Re: what e-fans are you guys running??

What's this going into? Many options available. Depends on what he wants to spend. And the look he is after. Many things through summit and jeg's. I am running the Entropy BB aluminum radiator with dual spal fans bought through ebay. Total cost about $720 including wiring harness and shipping. I don't have any issues with over heating but mine is not in a drag race setup. Sorry didn't pay attention to your infor at the bottom of your post. But check out the hp rating of the Entropy. It is a nice unit. Iam not at the hp as your fathers cars but it will work and fit to his core support. Just need some well nuts and the upper radiator hose for a 68 with a/c.

Last edited by tgifford5; Jul 27th, 10 at 08:36 PM. Reason: Correction and additional info.
tgifford5 is offline  
post #3 of 12 (permalink) Old Jul 27th, 10, 09:53 PM Thread Starter
Senior Tech
Brian
 
Join Date: Apr 2009
Location: tacoma, wa
Posts: 236
Send a message via AIM to joyride_
Re: what e-fans are you guys running??

69 camaro...he isn't looking at spending alot. haha that's for sure.

Brian
MY RIDE

01 S10 Xtreme 2/3 drop, BUILT 4.3L v6, 5spd
DADS RIDE
69 Camaro 500+ hp 355, t400, currie ford 9inch 4.56 gears, 100 shot
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
joyride_ is offline  
 
post #4 of 12 (permalink) Old Jul 28th, 10, 03:47 PM
Senior Tech
george
 
Join Date: Sep 2006
Location: detroit
Posts: 2,292
Re: what e-fans are you guys running??

I run dual spals,but have cooled many a big block with Flexalites Black Majic fully shrouded single fan on small core surfaces.

George
68 Camaro
8-71 blown 461 Rat on E-85
fatblock is offline  
post #5 of 12 (permalink) Old Jul 28th, 10, 09:55 PM
Senior Tech
Steve
 
Join Date: Jun 2005
Location: Melbourne, Australia
Posts: 2,864
Re: what e-fans are you guys running??

Put that flex fan in the bin and buy an OE 7 blade clutch fan.. It'll move more air than any e-fan too.

As the name says, "flex" fans don't push air, instead they flex. What's the point in that? They're like using a rubber wrench.

Nov 68 Van Nuys. 327 floor-shift-auto, Frost Green and not much else when new.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BlackoutSteve is offline  
post #6 of 12 (permalink) Old Jul 29th, 10, 05:05 AM
Senior Tech
 
Join Date: Apr 2002
Location: Watertown,NY
Posts: 186
Re: what e-fans are you guys running??

I run a lincoln mark VIII on my 427 SBC with a 4 row brass radiator and it cools great even setting in 95 deg temps. It moves alot of air and it is wired for low and high speed but never gets to high speed.
Riley is offline  
post #7 of 12 (permalink) Old Jul 29th, 10, 07:24 AM
Senior Tech
Bryan Hall
 
Join Date: Oct 2005
Location: Zachary, Louisiana
Posts: 1,143
Re: what e-fans are you guys running??

another one for the lincoln mark viii fan on a 4 core rad...

My car pics...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

dallas car show pics plus some of the cars i am building at work

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
importkiller69ss is offline  
post #8 of 12 (permalink) Old Jul 30th, 10, 08:36 PM
Senior Tech
 
Join Date: Jul 2005
Location: California
Posts: 2,353
Re: what e-fans are you guys running??

The taurus fan works, I have one. Just get a junk yard one.
The Mark VIII fan may be too deep for a big block. I think the taurus may clear.
A big block radiator is the biggest radiator that fits easily, summit sells an aluminum piece thats fairly nice.
400bird is offline  
post #9 of 12 (permalink) Old Jul 31st, 10, 09:23 AM
Gold Lifetime Member
Bill
 
bill3337's Avatar
 
Join Date: May 2008
Location: Victoria, BC Canada
Posts: 364
Re: what e-fans are you guys running??

I have to agree with the seven bladed OE steel fan. When I was having heating problems I tried them all......from Spal to Zirgo and all the flex fans I could find as well as all the 'water wetter" products. I tried the 4 bladed OE fan as well, and that helped, but not enough. I switched to the seven bladed OE fan and that did the trick. I have to admit though that the biggest issue with over heating is usually in the engine, not in the fan, as it was in my case, but the 7 bladed fan solved my problem till I figured out the real problem in the engine.
bill3337 is offline  
post #10 of 12 (permalink) Old Aug 9th, 10, 04:32 PM Thread Starter
Senior Tech
Brian
 
Join Date: Apr 2009
Location: tacoma, wa
Posts: 236
Send a message via AIM to joyride_
Re: what e-fans are you guys running??

alrighty...well...we just went and got a taurus 3.8l fan...and it seems as if it's a puller, and doesn't look like the taurus fan im using which works fine on my s10 w/ a built v6...

will this puller fan work or should i return it for hopefully the one i got, which i assume is the 3.0? im not sure...

400bird, do you by any chance know what yr your fan came off of, and if its a 3.8 or 3.0?

thanks for the help too all, appreciate it.

Brian
MY RIDE

01 S10 Xtreme 2/3 drop, BUILT 4.3L v6, 5spd
DADS RIDE
69 Camaro 500+ hp 355, t400, currie ford 9inch 4.56 gears, 100 shot
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
joyride_ is offline  
post #11 of 12 (permalink) Old Aug 9th, 10, 05:53 PM
Senior Tech
 
Join Date: Jul 2005
Location: California
Posts: 2,353
Re: what e-fans are you guys running??

Well, mine is a puller, but I don't remember for sure which engine the donor had.
If you search some old posts you should find the answer, probably 3.8.
400bird is offline  
post #12 of 12 (permalink) Old Aug 10th, 10, 12:50 PM Thread Starter
Senior Tech
Brian
 
Join Date: Apr 2009
Location: tacoma, wa
Posts: 236
Send a message via AIM to joyride_
Re: what e-fans are you guys running??

thanks...we're just gonna go with it. it seems nice. it spins hard when its working...now im having an issue wiring it up..?

EDIT : got it running right and its fine now w/ the toggle switch we have it setup with...appreciate the help everyone!

Brian
MY RIDE

01 S10 Xtreme 2/3 drop, BUILT 4.3L v6, 5spd
DADS RIDE
69 Camaro 500+ hp 355, t400, currie ford 9inch 4.56 gears, 100 shot
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by joyride_; Aug 10th, 10 at 04:40 PM. Reason: dumbass
joyride_ is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome