Another Top Switch Question - Team Camaro Tech
Convertibles Convertible Q&A's

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jul 7th, 19, 04:14 PM Thread Starter
Gold Lifetime Member
John
 
Join Date: Mar 2018
Location: Dallas, TX
Posts: 189
Garage
Another Top Switch Question

I replaced the top switch, similar to the kind the PO did. It is a 30 amp toggle switch. The motor turns on close cycle, but not open.

So, what is the next thing to check? Didn't want to rip out the back seat and check connections, if there is something else to check.

Thanks

1967 RS/SS Vert (non matching)
aggiegoalie is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jul 7th, 19, 05:16 PM
Senior Tech
Jim
 
Join Date: Dec 2002
Location: Saint Louis, Missouri
Posts: 1,085
Re: Another Top Switch Question

Quote:
Originally Posted by aggiegoalie View Post
I replaced the top switch, similar to the kind the PO did. It is a 30 amp toggle switch. The motor turns on close cycle, but not open.

So, what is the next thing to check? Didn't want to rip out the back seat and check connections, if there is something else to check.

Thanks
If it's similar to what the PO did, was it right with the wiring and style of switch before you replaced it ?.

This 30A toggle switch, does it have three connections or two ?.

Do you have and know how to use a test light and/or volt meter ?

Jim

1974 Spirit Of America Nova (being restored), 1973 Nova Custom, 1968 Chevy II (Garage Find 2012)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SOA-Nova is offline  
post #3 of 4 (permalink) Old Jul 7th, 19, 05:25 PM Thread Starter
Gold Lifetime Member
John
 
Join Date: Mar 2018
Location: Dallas, TX
Posts: 189
Garage
Re: Another Top Switch Question

Switch has worked like a champ. Usually store closed. Went to take it out it wouldn't open. So, bought another switch. It is 3 connector. On/off/on.

Sent from my SM-G950U using Tapatalk

1967 RS/SS Vert (non matching)
aggiegoalie is offline  
 
post #4 of 4 (permalink) Old Jul 10th, 19, 05:15 AM
Senior Tech
Bill
 
Join Date: May 2004
Location: connecticut
Posts: 585
Re: Another Top Switch Question

I have always run engine when operating the top and have had no issues , helps top motor from working harder
bills69 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome